Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: eine Konstellation von der Summierung ausschließen


Aufgabe
In Spalte B sollen alle Werte addiert werden, wenn die entsprechende Nummer in Spalte A mit 7010 oder mit 7012 beginnt; nicht aber die Nummern mit 70129.

       A               B               C       
1 7011-a  22  
2 70106-as  3   
3 70127-ba  10   
4 6900-ds  15   
5 70129-a  20   
6 70122-ab  5   
7 70129-abc  20   
8 70134-ds  17   
9 7010-bas  3   
10 701250-bas  1   



Lösung
=SUMMENPRODUKT((LINKS(A1:A100;4)={"7010"."7012"})*B1:B100)-SUMMENPRODUKT((LINKS(A1:A100;5)="70129")*B1:B100)

kann man zusammenfassen zu:

=SUMMENPRODUKT((LINKS(A1:A100;{4.4.5})={"7010"."7012"."70129"})*{1.1.-1}*B1:B100)