Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Textfunktionen - BEITRAG: eine Telefon-Nr. in Vorwahl und Rufnummer trennen


Aufgabe
In einer Telefonliste hast Du Telefonnummern mit oder ohne Vorwahl.
Vorwahl und Rufnummer sind durch Leerzeichen, Bindestrich (-) oder slash (/) getrennt.

       A               B               C       
1 Telefon-Nr.  Vorwahl  Rufnummer  
2 089-7012345  089  7012345  
3 0221 66452  0221  66452  
4 5142012    5142012  
5 8115-1    8115-1  
6 0761-878746-0  0761  878746-0  
7 06101/271923  06101  271923 



Lösung
Die Vorwahl in B2 erhältst Du mit:
=WENN(LINKS(A2)*1>0;"";LINKS(A2;MIN(SUCHEN({" "."-"."/"};A2&" -/"))-1))

Die Rufnummer in C2:
=WENN(LINKS(A2)*1>0;A2;GLÄTTEN(TEIL(A2;MIN(SUCHEN({" "."-"."/"};A2&" -/"))+1;19)))
Oder, wenn das Vorwahlergebnis in B2 verwendet wird:
=WENN(LINKS(A2)*1>0;A2;GLÄTTEN(TEIL(A2;LÄNGE(B2)+2;19)))


Erläuterung
GLÄTTEN, falls mehrere Leerzeichen als Trennung verwendet werden und dann nicht *1, falls in einer Rufnummer ein weiteres Sonderzeichen vorkommen kann.