Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Sonstiges - BEITRAG: einen (Geld-)Betrag optimal stückeln


Aufgabe
Ein Betrag (Geld / Gewicht / etc.) soll entsprechend einer vorgegebenen Stückelung optimal aufgeteilt werden.

       A               B               C               D               E       
1 Stückelung  Betrag    Scheine/Münzen  Anzahl  
2 500  1458,34    500  2  
3 200      200  2  
4 100      50  1  
5 50      5  1  
6 20      2  1  
7 10      1  1  
8 Scheine    0,2  1  
9 2  Münzen    0,1  1  
10 1      0,02  2  
11 0,5         
12 0,2         
13 0,1         
14 0,05         
15 0,02         
16 0,01         



Lösung
Ab Zelle A2 steht die vorzugebende Stückelung - im Beispiel ist's der Euro.

in D2 steht:
{=MAX((A$2:A$35<=B2)*A$2:A$35)}
in D3 steht:
{=MAX((A$2:A$35<=RUNDEN(B$2-SUMME((D$2:D2)*(E$2:E2));5))*A$2:A$35)}

in E2 steht:
=GANZZAHL(B$2/D2)
in E3:
{=WENN(D3=0;0;GANZZAHL(RUNDEN((B$2-SUMME((D$2:D2)*(E$2:E2)));5)/D3))}

D3 und E3 runterkopieren.

zur Kontrolle muß
=SUMMENPRODUKT(D2:D20;E2:E20)
dem Betrag in B2 entsprechen

DOWNLOAD
In H6 wird der Betrag eingegeben; ab L6 runter: die Stückelung
In F2 ist die Überschrift. Beginnt diese mit Euro, ist die Stückelung ab L6 egal; - dann wird automatisch die Euro-Stückelung herangezogen.


Erläuterung
Mit bedingter Formatierung Zelle D2 bis E20 (D2 ist die aktive Zelle) - Formel ist: =$D2<5 und ein Format aussuchen kann man noch (bei Währungen < 5 = Euro) Münzen von Scheinen optisch trennen.

RUNDEN(....;5) erscheint überflüssig; - ohne wird aber machmal ein Cent geschlampt (Fließkommaproblematik).