Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Sonstiges - BEITRAG: gestaffelte Preise nehmen prozentual ab


Aufgabe
Der Grundpreis für die erste Staffelung nimmt für alle weiteren Staffelungen prozentual ab - also nicht linear.

       A               B               C               D               E       
1 7.832  KG    1000  1250  
2 1,25  Preis/KG    1000  1125  
3 10%  Reduktion pro Staffel    1000  1012,5  
4 1.000  Staffelung    1000  911,25  
5       1000  820,125  
6 7.018,72      1000  738,1125  
7       1000  664,30125  
8       832  497,428776  
9       0  
10       0  
11       0  
12      



Lösung
in A1 steht die Bestellmenge in KG
in A2 steht der Grundpreis pro KG
in A3 steht die prozentuale Reduzierung pro Staffelung
in A4 steht die Staffelung

pro Staffel aufgedröselt.
in D1 steht:
=MAX(0;MIN(A$1-A$4*(ZEILE(A1)-1);A$4))
in E1 steht:
=D1*A$2*(1-A$3)^(ZEILE(A1)-1)
beide runterkopieren

Das Ergebnis in A6 ist dann: =SUMME(E:E)

in einer Formel (ohne die Aufdröselung in den Spalten D und E):
=WENN(A1>A4;A4*SUMMENPRODUKT(A2*(1-A3)^(ZEILE(INDIREKT(1&":"&GANZZAHL(A1/A4)))-1));0)+REST(A1;A4)*A2*(1-A3)^GANZZAHL(A1/A4)