Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Statistik - BEITRAG: höchster Gewinn/Verlust von Börsenkursen


Aufgabe
Es soll der höchste Gewinn und der höchste Verlust von Börsenkursen mit dem entsprechenden Datum ermittelt werden.

       A               B               C               D               E               F       
1 4960  27.02.2002    149  04.03.2002  höchster Gewinn  
2 5039  28.02.2002    -98  20.03.2002  höchster Verlust  
3 5097  01.03.2002         
4 5246  04.03.2002         
5 5229  05.03.2002         
6 5285  06.03.2002         
7 5289  07.03.2002         
8 5360  08.03.2002         
9 5341  11.03.2002         
10 5276  12.03.2002         
11 5246  13.03.2002         
12 5277  14.03.2002         
13 5401  15.03.2002         
14 5426  18.03.2002         
15 5463  19.03.2002         
16 5365  20.03.2002         
17 5349  21.03.2002         


Lösung
Die Kurse stehen in Spalte A; - das entsprechende Datum in Spalte B.

höchster Kursgewinn in D1:
{=MAX(A2:A1001-A1:A1000)}

höchster Kursverlust in D2 (wegen Leerzellen nach dem letzten Kurs etwas länger):
{=MIN(A2:INDIREKT("A"&ANZAHL(A:A))-A1:INDIREKT("A"&ANZAHL(A:A)-1))}

Datum in E1:
{=INDEX(B:B;VERGLEICH(D1;A$2:A$1001-A$1:A$1000;0)+1)}
E1 nach E2 kopieren.

Die Anzahl der Kursgewinne liefert:
=SUMMENPRODUKT((A2:A1001>A1:A1000)*1)