Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Zahlenformate - BEITRAG: immer auf volle Zehnerpotenzen aufrunden (das Rad zum 2. mal)


Aufgabe
Eine Zahl soll immer auf volle Zehnerpotenzen aufgerundet werden.
Dabei sollen negative Zahlen absolut aufgerundet werden (was ja eigentlich abrunden bedeutet) bzw. betragsmäßig.

       A               B               C               D       
1 740  1000  1000  1000  
2 0,00567  0,01  0,01  0,01  
3 7,3  10  10  10  
4 0  
5 -100  -100  -100  -100  
6 -0,001  -0,001  -0,001  -0,001  
7 -145  -200  -1000  -100  
8 -4,5  -5  -10  -1  
9 -0,0025  -0,01  -0,01  -0,001  
10        
11   nur positiv  negativ:  negativ:  
12     absolut  Betrag 



Lösung
nur positiv - in B1:
=WENN(A1=0;0;AUFRUNDEN(A1;-LÄNGE(GANZZAHL(A1)-(REST(A1;1)=0))+(A1<=1)*LÄNGE(GANZZAHL(1/A1))))

negativ absolut - in C1:
=VORZEICHEN(A1)*WENN(A1=0;0;AUFRUNDEN(ABS(A1);-LÄNGE(GANZZAHL(ABS(A1))-(REST(ABS(A1);1)=0))+(ABS(A1)<=1)*LÄNGE(GANZZAHL(1/ABS(A1)))))

negativ Betrag - in D1:
=VORZEICHEN(A1)*WENN(A1=0;0;AUFRUNDEN(ABS(A1);-LÄNGE(GANZZAHL(ABS(A1))-(REST(ABS(A1);1)=0))+(ABS(A1)<=1)*LÄNGE(GANZZAHL(1/ABS(A1))))/WENN(UND(A1<0;REST(LOG(ABS(A1));1)>0);10;1))


Erläuterung
Das Rad zum zweiten mal erfinden: bei über 460 Beiträgen = ca. 3.000 Formeln kann's ja mal vorkommen, daß man etwas nicht parat hat.
Obiges (für positive Zahlen und negative Zahlen/absolut) macht ja unsere Uralt-Formel Nr. 179 von KlausCDN:
=AUFRUNDEN(A1;-1-GANZZAHL(LOG10(ABS(A1))))
WF