Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Datum/Zeit - BEITRAG: kurzer Monat ausgeschrieben sonst 3 Buchstaben Punkt *


Aufgabe
Der Monatsname in einem Datum soll vollständig ausgeschrieben werden, wenn er nur aus bis zu 4 Buchstaben besteht.
Darüber soll er mit 3 Buchstaben und Punkt abgekürzt werden.

Also:

       A               B       
1 1. Januar 2001  01. Jan. 2001  
2 1. Februar 2001  01. Feb. 2001  
3 1. März 2001  01. März 2001  
4 1. April 2001  01. Apr. 2001  
5 1. Mai 2001  01. Mai 2001  
6 1. Juni 2001  01. Juni 2001  
7 1. Juli 2001  01. Juli 2001  
8 1. August 2001  01. Aug. 2001  
9 1. September 2001  01. Sep. 2001  
10 1. Oktober 2001  01. Okt. 2001  
11 1. November 2001  01. Nov. 2001  
12 1. Dezember 2001  01. Dez. 2001 
Lösung
das Datum steht in A1

=TEXT(A1;"TT.")&WENN(ODER(MONAT(A1)=3;MONAT(A1)=5;MONAT(A1)=6;MONAT(A1)=7);TEXT(A1;"MMMM");TEXT(A1;"MMM."))&TEXT(A1;"JJJJ")

kürzer von Peter Dorigo:
=WENN(ODER(MONAT(A1)={3;5;6;7});TEXT(A1;"TT. MMMM JJJJ");TEXT(A1;"TT. MMM. JJJJ"))

und nochmal 15 Zeichen weniger - 10.10.2003:
=TEXT(A1;"TT. MMM"&WENN(LÄNGE(TEXT(A1;"MMMM"))>4;". ";"M ")&"JJJJ")