Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: nicht zusammenhängende Postleitzahlenbereiche zuordnen


Aufgabe
In Spalte A stehen Postleitzahlenbereiche von und in Spalte B Bereiche bis. In Spalte C steht der Ortsname.
Jetzt ist es aber so, dass der von-Bereich in A2 NICHT B1+1 ist, sondern da eine Lücke klafft. Zudem kann ein Ort nur aus einer einzigen Postleitzahl bestehen - also ohne bis.
In E1 soll der Ort mit der Postleitzahl in D1 bestimmt werden.

       A               B               C               D               E       
1 PLZ - von  bis  Ort  47810  Krefeld  
2 47051  47279  Duisburg  41060  gibt's nicht  
3 40210  40629  Düsseldorf     
4 41812    Erkelenz     
5 41515  41517  Grevenbroich     
6 47798  47838  Krefeld     
7 40764    Langenfeld     
8 40667  40670  Meerbusch     
9 41061  41239  Mönchengladbach     
10 40789    Monheim     
11 41460  41472  Neuss     
12 40878  40885  Ratingen     


Lösung
in E1 steht:
{=WENN(SUMME((D1>A1:A99)*(D1<=B1:B99)+(D1=A1:A99))=0;"gibt's nicht";INDEX(C:C;MAX(((D1>A1:A99)*(D1<=B1:B99)+(D1=A1:A99))*ZEILE(1:99))))}

Wer will, kann sich einer Macke der Funktion INDEX bedienen, denn =INDEX(C:C;0) ist identisch zu =INDEX(C:C;1)

{=INDEX(C:C;MAX(((D1>A1:A99)*(D1<=B1:B99)+(D1=A1:A99))*ZEILE(1:99)))}
ergäbe bei keinem Treffer den Inhalt von D1 - hier also "Ort".


Erläuterung
Obige Tabelle muss nicht nach den Postleitzahlen sondern kann auch (wie hier) alphabetisch nach den Orten sortiert sein.