Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: nur Werte einer bestimmten Kalenderwoche addieren


Aufgabe
wie der Titel schon sagt.

Lösung
In Spalte A1 bis A500 stehen (unsortiert) Datümer
In Spalte B die zu addierenden Werte.
Die Nummer der gewünschten Kalenderwoche steht in C1; - die Jahreszahl in C2.

{=SUMME(WENN(A1:A500<>"";(KÜRZEN((A1:A500-WOCHENTAG(A1:A500;2)-DATUM(JAHR(A1:A500+4-WOCHENTAG(A1:A500;2));1;-10))/7)=C1)*(JAHR(A1:A500)=C2)*B1:B500))}