Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: nur einzeln vorkommende Einträge auflisten


Aufgabe
In Spalte A stehen Namen/Begriffe/Zahlen, die auch mehrfach vorkommen können. Es sollen jetzt nur die aufgelistet werden, die solo sind.

Lösung
{=WENN(SUMME((ZÄHLENWENN(A$1:A$99;A$1:A$99)=1)*1) < ZEILE(A1);"";INDEX(A:A;KKLEINSTE(WENN(ZÄHLENWENN(A$1:A$99;A$1:A$99)=1;ZEILE($1:$99));ZEILE(A1))))}
bzw. ab Excel 2007
{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ZÄHLENWENN(A$1:A$99;A$1:A$99)=1;ZEILE($1:$99));ZEILE(A1)));"")}
runterkopieren

Erläuterung
Sollen mehrfach vorkommende Namen einzeln berücksichtigt werden, siehe Formel Nr. 194 in Listen/Datensätze (Spezialfilter ohne Dup)