Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Summenfunktionen - BEITRAG: summieren von Einzelposten bis ein Betrag überschritten wird


Aufgabe
Du hast einen Warenbestand und für die Folgemonate gehen laufend Bestellungen ein. Du willst jetzt wissen, bis wann der Bestand noch ausreicht.

       A               B               C               D               E               F               G               H       
1 Bestand  Monat  bestellt           
2 856  01/2014  423           
3   02/2014  217           
4 reicht bis  03/2014  131           
5 04/2014  04/2014  72           
6   05/2014  56           
7   06/2014  45           
8                
9                
10   Monat  01/2014  02/2014  03/2014  04/2014  05/2014  06/2014  
11   bestellt  423  217  131  72  56  45 


Lösung
Der Bestand steht in A2.

A) die Tabelle ist senkrecht aufgebaut (Spalten B2 bis C99):
{=WENNFEHLER(INDEX(B2:B99;MAX(WENN(TEILERGEBNIS(9;BEREICH.VERSCHIEBEN(C2;;;ZEILE(1:99)))<=A2;ZEILE(1:99))));"Ende")}
einfacher von neopa:
{=MAX((SUMMEWENN(B2:B99;"<="&B2:B99;C2:C99)<=A2)*B2:B99)}

B) die Tabelle ist waagerecht aufgebaut (Zeilen C10 bis Z11):
{=WENNFEHLER(INDEX(C10:Z10;MAX(WENN(TEILERGEBNIS(9;BEREICH.VERSCHIEBEN(C11;;;;ZEILE(1:99)))<=A2;ZEILE(1:99))));"Ende")}
bzw.
{=MAX((SUMMEWENN(C10:Z10;"<="&C10:Z10;C11:Z11)<=A2)*C10:Z10)}

Erläuterung
senkrecht zu waagerecht sind 3 zu 4 Semikolons hintereinander in BEREICH.VERSCHIEBEN: 3 für die Höhe und 4 für die Breite