Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Listen/Datensätze - BEITRAG: ungleichmäßige Spaltenteile zeilenweise (mit Lücken) umsortieren.


Aufgabe
In Spalte A stehen Namen und darunter eine oder mehrere Zusatzinformationen.
Die damit korrespondierenden Einträge stehen in Spalte B.
Die Namen sollen jetzt zeilenweise mit den Zusätzen an der richtigen Stelle aufgelistet werden.

       A               B               C               D               E               F               G               H       
1 Name  Bucher    Name  Vorname  Telefon  handy  email  
2 Vorname  Anne  Bucher  Anne  069-98765  0172-4560789  Anne.Bucher@t-online.de  
3 Telefon  069-98765  Chemiewerke    089-1233587     
4 handy  0172-4560789  Delugré  Michelle    0179-1234567   
5 email  Anne.Bucher@t-online.de  11  em Pöötzke    0211-326973     
6 Name  Chemiewerke  13  excelformeln        kontakt@excelformeln.de  
7 Telefon  089-1233587  15  Getränke    0211-6178550     
8 Name  Delugré  17  Kremer  Marco      Kremer@hotmail.com  
9 Vorname  Michelle  1000           
10 handy  0179-1234567  1000           
11 Name  em Pöötzke  1000           
12 Telefon  0211-326973             
13 Name  excelformeln             
14 email  kontakt@excelformeln.de             
15 Name  Getränke             
16 Telefon  0211-6178550             
17 Name  Kremer             
18 Vorname  Marco             
19 email  Kremer@hotmail.com             

Lösung
in C2 (Hilfsspalte - ausblenden) steht:
{=WENN(ZÄHLENWENN(INDIREKT("A"&C1+1):A$1000;"Name")=0;1000;KKLEINSTE(WENN((A$1:A$1000="Name");ZEILE($1:$1000));ZEILEN($1:1)))}
runterkopieren

in D2 steht:
=WENN(ISTFEHLER(VERGLEICH(D$1;INDIREKT("A"&$C2):INDIREKT("A"&$C3);0));"";INDEX(INDIREKT("B"&$C2):INDIREKT("B"&$C3);VERGLEICH(D$1;INDIREKT("A"&$C2):INDIREKT("A"&$C3);0)))
bis H2 und soweit wie benötigt runterkopieren