Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Sonstige - BEITRAG: verschachtelte Listboxen


Aufgabe
Listboxen hierarchisch schachteln. Funktioniert wie die Kategorieauswahl beim Verkauf eines Artikels bei Ebay.

DOWNLOAD (24kb)




Lösung
Spalte D enthält die Nummer des Elementes dem das aktuelle Element direkt untergeordnet ist. Es können beliebig viele Level dargestellt werden.
Die Liste muss sortiert sein, 1. nach Level und 2. nach Parent.

Formeln
G4:=ZÄHLENWENN($D:$D;G3)
H3:{=WENN(G2>G4;NV();VERGLEICH(G$1&G$3;$C$1:$C$100&$D$1:$D$100;0)+G2-2)}
Beide Formeln nach rechts kopieren, bei 4 Ebenen bis Spalte J.

G5:{=WENN($F5>G$4;"";INDEX($B:$B;VERGLEICH(G$1&G$3;$C$1:$C$100&$D$1:$D$100;0)+$F5-1)&">")}
Formel nach unten und rechts kopieren