Microsoft Excel

Das Portal zum Thema Excel-Formeln

Gruppe: Datum/Zeit - BEITRAG: xter-Arbeitstag eines Monats


Aufgabe
Erster, letzter oder soundsovielter Arbeitstag eines Monats sowie Anzahl Arbeitstage eines Monats sollen berechnet werden


Lösung
in A1 steht ein (ausgeschriebenes) Datum

erster (geht sicher kürzer)
=DATUM(JAHR(A1);MONAT(A1);1)+(7-WOCHENTAG(DATUM(JAHR(A1);MONAT(A1););2))*(WOCHENTAG(DATUM(JAHR(A1);MONAT(A1);1);2)>5)
Claus Busch:
=DATUM(JAHR(A1);MONAT(A1);1)+WAHL(WOCHENTAG(DATUM(JAHR(A1);MONAT(A1);1);2);;;;;;2;1)
Franz Pölt::
=A1-TAG(A1)+3-MIN(2;REST(A1-TAG(A1)+1;7))

x-ter (x steht in B1); - siehe Formel Nr. 13 (Arbeitstag)
{=DATUM(JAHR(A1);MONAT(A1);)+KKLEINSTE(WENN(WOCHENTAG(DATUM(JAHR(A1);MONAT(A1);)+(ZEILE(INDIREKT("1:"&B1*2))-1))<6;ZEILE(INDIREKT("1:"&B1*2)));B1)}

Summe in einem Monat; - siehe Formel Nr. 251
{=SUMME((WOCHENTAG(ZEILE(INDIREKT(DATUM(JAHR(A1);MONAT(A1);1)&":"&DATUM(JAHR(A1);MONAT(A1)+1;)));2)<6)*1)}

letzter, von Pedor
=DATUM(JAHR(A1);MONAT(A1)+1;)-MAX(;WOCHENTAG(DATUM(JAHR(A1);MONAT(A1)+1;);2)-5)

x-letzter (x steht in B1)
{=DATUM(JAHR(A1);MONAT(A1)+1;1)-KKLEINSTE(WENN((WOCHENTAG(DATUM(JAHR(A1);MONAT(A1)+1;1)-(ZEILE(INDIREKT("1:"&B1*9))+1))<6);ZEILE(INDIREKT("1:"&B1*9)));B1)}