Microsoft Excel

Herbers Excel/VBA-Archiv

Prozentual ausrechnen

Betrifft: Prozentual ausrechnen von: Susann
Geschrieben am: 11.08.2008 12:23:50

Hallo liebe Excell-Freunde,

ich möchte Folgendes in einer Formel von Excel ausrechnen lassen:

A1: 50 B1: 0,10 €
A2: 20 B2: 0,10 €
A3: 5 B3: 0,10 €
A4: 1000 B4: 0,50 €

jetzt sollen die Werte prozentual zueinander gerechnet werden, sprich 1075 gesamt, davon sind 50 = 4,7 %; 20 sind 1,86 %; 5 sind 0,46 % und die 1000 ja 93 %.

Die Werte in A sind Minuten, nun möchte ich 200 Minuten prozentual abziehen, also von den 1000 Minuten am Meisten und dass dann aber in Bezug auf die Preise.

4,7 % mal 0,1 €
1,86 % mal 0,1 €
0,46 % mal 0,1 €
93 % mal 0,5 €

Wenn die Preise alle gleich wären, wäre es ja kein Thema, da ich dann einfach 100 Minuten mal 0,1 € rechnen würde. (=Max(-10€;-Summe(B1+B2+B3+B4))

Zu beachten ist aber noch, dass, er erkennen soll, dass nicht immer 100 voll sind, sprich auch nur mal 50 Minuten als Ausgangswert sind.

Ich hoffe, ich konnte rüberbringen, was ich gerne machen würde, und würde mich über eine Antwort von euch freuen.

Vielen lieben Dank im Voraus.

  

Betrifft: AW: Prozentual ausrechnen von: David
Geschrieben am: 11.08.2008 13:17:55

...Ich hoffe, ich konnte rüberbringen, was ich gerne machen würde...
Nicht ganz. Ich bin jetzt soweit:


Tabellenblattname: Tabelle3

 

A

B

C

D

1

50

0,1

4,65116279069767

9,30232558139535

2

20

0,1

1,86046511627907

3,72093023255814

3

5

0,1

0,465116279069767

0,930232558139535

4

1000

0,5

93,0232558139535

186,046511627907

5

 

 

 

 

6

1075

 

100

200


Benutzte Formeln:
C1: =A1/$A$6%
D1: =$D$6*C1%
C2: =A2/$A$6%
D2: =$D$6*C2%
C3: =A3/$A$6%
D3: =$D$6*C3%
C4: =A4/$A$6%
D4: =$D$6*C4%
A6: =SUMME(A1:A5)
C6: =A6/$A$6%

und nun?

Gruß

David


  

Betrifft: AW: Prozentual ausrechnen von: uwi
Geschrieben am: 11.08.2008 14:30:27

War das so zu verstehen?
Würde mir eher einleuchten als Davids Deutungsweise

A1: 50
A2: 20
A3: 5
A4: 1000
A6: Summe aus A1:A4: 1075

C1: =A1/$A$6% = 4,651163%
C2: =A2/$A$6% = 1,860465%
C3: =A3/$A$6% = 0,465116%
C4: =A4/$A$6% = 93,023256%

D5: Abzuziehende Minuten: 200
D6: =$A$6-D5 = 875
D1: =$D$6*C1 = 41
D2: =$D$6*C2 = 16
D3: =$D$6*C3 = 4
D4: =$D$6*C4 = 814
E1: = B1 * D1 = 4,07€
E2: = B2 * D2 = 1,63 €
E3: = B3 * D3 = 0,41 €
E4: = B4 * D4 = 406,98 €

Gruß Uwi


  

Betrifft: AW: Prozentual ausrechnen von: Susann
Geschrieben am: 14.08.2008 08:52:39

Hallo ihr Beiden,

vielen Dank für die Antworten. Das war der Ansatz zur Lösung. Manchmal macht man es sich einfach nur zu schwer. :-)


 

Beiträge aus den Excel-Beispielen zum Thema "Prozentual ausrechnen"