Microsoft Excel

Herbers Excel/VBA-Archiv

Anzahl Zellen - zwischen 80 und 200 - Filter

Betrifft: Anzahl Zellen - zwischen 80 und 200 - Filter von: dwettig
Geschrieben am: 13.08.2008 09:27:02

Hallo,

ich möchte die Anzahl von Zellen zählen deren INhalt zwischen a und b liegt. Erschwerend kommt hinzu, das es nur für gefilterte Zeilen gelten soll.

Ich habe es bisher versucht mit:

=ZÄHLENWENN(AD12:AD1500;">80")-ZÄHLENWENN(AD12:AD1500;">200")



Da werden aber auch die ausgeblendeten Zeilen mitgewertet.

Hat jemand eine Idee ??

Gruß
DW

  

Betrifft: AW: Anzahl Zellen - zwischen 80 und 200 - Filter von: Andreas Emmert
Geschrieben am: 13.08.2008 09:43:32

Hallo,

mein Vorschlag wäre mit einer Hilfsspalte, der Funktion Teilergebnis und Auswertung der vorhandenen Werte, also so bspw:

Tabelle1

 ABC
185 85
2210 210
389 89
4300 300
5   
6  2

Formeln der Tabelle
ZelleFormel
C1=TEILERGEBNIS(109;A1)
C2=TEILERGEBNIS(109;A2)
C3=TEILERGEBNIS(109;A3)
C4=TEILERGEBNIS(109;A4)
C6{=SUMME(WENN((C1:C4>80)*(C1:C4<200); 1;0))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Grüße
Andreas


  

Betrifft: klappt nicht bei XL97 o.w.T. von: Reinhard
Geschrieben am: 13.08.2008 09:54:02




  

Betrifft: AW: Anzahl Zellen - zwischen 80 und 200 - Filter von: Bernd
Geschrieben am: 13.08.2008 09:43:44

Hallo DW!

Schau mal unter: http://www.excelformeln.de/formeln.html?welcher=259

Gruß Bernd


  

Betrifft: Zählen in gefilterter Liste von: backowe
Geschrieben am: 13.08.2008 09:46:18

Hi,

probiere es mal so:

=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("AD"&ZEILE(12:1500)))*(AD12:AD1500>=80)*(AD12:AD1500<=200))

Gruß Jürgen


  

Betrifft: AW: Zählen in gefilterter Liste von: dwettig
Geschrieben am: 13.08.2008 09:52:27

Hallo Jürgen, Berndt, Andreas,

danke für eure schnelle Hilfe.

Ich habe mich für die Lösung von Jürgen entscheiden das sie ohne "Hilfszellen" auskommt.

Danke - Problem gelöst :-)

Gruß
DW


  

Betrifft: AW: Zählen in gefilterter Liste von: Andreas Emmert
Geschrieben am: 13.08.2008 09:57:12

Hallo Jürgen,

m. E. muss dann aber TEILERGEBNIS(103; .... ) lauten, weil sonst die ausgeblendeten Zellen mit einbezogen werden.

Grüße
Andreas


  

Betrifft: Nein, dem ist nicht so! :o) oT von: backowe
Geschrieben am: 13.08.2008 09:59:46




 

Beiträge aus den Excel-Beispielen zum Thema "Anzahl Zellen - zwischen 80 und 200 - Filter"