Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Anzahl Zellen - zwischen 80 und 200 - Filter

Anzahl Zellen - zwischen 80 und 200 - Filter
13.08.2008 09:27:02
dwettig
Hallo,
ich möchte die Anzahl von Zellen zählen deren INhalt zwischen a und b liegt. Erschwerend kommt hinzu, das es nur für gefilterte Zeilen gelten soll.
Ich habe es bisher versucht mit:
=ZÄHLENWENN(AD12:AD1500;">80")-ZÄHLENWENN(AD12:AD1500;">200")


Da werden aber auch die ausgeblendeten Zeilen mitgewertet.
Hat jemand eine Idee ?
Gruß
DW

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Anzahl Zellen - zwischen 80 und 200 - Filter
13.08.2008 09:43:32
Andreas
Hallo,
mein Vorschlag wäre mit einer Hilfsspalte, der Funktion Teilergebnis und Auswertung der vorhandenen Werte, also so bspw:
Tabelle1

 ABC
185 85
2210 210
389 89
4300 300
5   
6  2

Formeln der Tabelle
ZelleFormel
C1=TEILERGEBNIS(109;A1)
C2=TEILERGEBNIS(109;A2)
C3=TEILERGEBNIS(109;A3)
C4=TEILERGEBNIS(109;A4)
C6{=SUMME(WENN((C1:C4>80)*(C1:C4<200); 1;0))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Grüße
Andreas

Anzeige
klappt nicht bei XL97 o.w.T.
13.08.2008 09:54:02
Reinhard


Zählen in gefilterter Liste
13.08.2008 09:46:00
backowe
Hi,
probiere es mal so:
=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("AD"&ZEILE(12:1500)))*(AD12:AD1500>=80)*(AD12:AD1500 Gruß Jürgen

AW: Zählen in gefilterter Liste
13.08.2008 09:52:00
dwettig
Hallo Jürgen, Berndt, Andreas,
danke für eure schnelle Hilfe.
Ich habe mich für die Lösung von Jürgen entscheiden das sie ohne "Hilfszellen" auskommt.
Danke - Problem gelöst :-)
Gruß
DW

Anzeige
AW: Zählen in gefilterter Liste
13.08.2008 09:57:00
Andreas
Hallo Jürgen,
m. E. muss dann aber TEILERGEBNIS(103; .... ) lauten, weil sonst die ausgeblendeten Zellen mit einbezogen werden.
Grüße
Andreas

Nein, dem ist nicht so! :o) oT
13.08.2008 09:59:46
backowe

308 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige