Microsoft Excel

Herbers Excel/VBA-Archiv

Addition von angekreuzten Zellen

Betrifft: Addition von angekreuzten Zellen von: Dagmar GP
Geschrieben am: 15.08.2008 09:14:04

Hallo alle miteinander,

gibt es für folgende Aufgabe eine einfache Möglichkeit?

Ich habe eine Tabelle in der in der ersten Zeile Zahlen stehen. In den weiteren Zeilen werden mit x die Zellen angekreutz welche addiert werden sollen.

3. . .5. . .8. . .9. . .Summe
x . . . . . .x . . . . . . 11
. . . . x . . . . . . . . . 5
. . . . x . . . . .x. . . 14

So ähnlich sollte das aussehen. Ich hoffe ich konnte es einigermaßen erklären. Umständlich mit Hilfsspalten und Wenn-Funktion kriege ich es auch hin aber Ihr habt immer so super Lösungen.

Vielen Dank für Eure Hilfe

Dagmar

  

Betrifft: AW: Addition von angekreuzten Zellen von: David
Geschrieben am: 15.08.2008 09:18:07

So?


Tabellenblattname: Tabelle1

 

A

B

C

D

E

1

3

5

8

9

 

2

x

 

x

 

11

3

 

x

 

 

5

4

 

x

 

x

14


Benutzte Formeln:
E2: =SUMMEWENN(A2:D2;"x";$A$1:$D$1)
E3: =SUMMEWENN(A3:D3;"x";$A$1:$D$1)
E4: =SUMMEWENN(A4:D4;"x";$A$1:$D$1)

Rückmeldung wäre nett.

Gruß

David


  

Betrifft: AW: Addition von angekreuzten Zellen von: Rudi Maintaire
Geschrieben am: 15.08.2008 09:19:45

Hallo,
in der Art:
=SUMMENPRODUKT((A2:D2="x")*$A$1:$D$1)

Gruß
Rudi


 

Beiträge aus den Excel-Beispielen zum Thema "Addition von angekreuzten Zellen"