Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
KW in Datum umwandeln
07.10.2008 07:40:13
Jochen
Hallo Freunde,
wie kann ich aus dieser Angabe "08 / 01" das Datum "01.01.2008" erstellen.
08 = Jahr
01 = Kalenderwoche
Danke im voraus.
Jochen

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: KW in Datum umwandeln
07.10.2008 08:17:00
serge
Hallo joche
wenn in A1 dein "08 / 01" als text vorhanden ist dann : =DATUM(LINKS(A1;2)+2000;RECHTS(A1;2);1)
Serge
AW: KW in Datum umwandeln
07.10.2008 08:25:00
Jochen
Danke für schnelle Hilfe, klappt.
j.
AW: dann nimm mal 08 / 13 :-(
07.10.2008 08:37:39
UweD
die Lösung hat gar nichts mit KW zu tun.
Gruß UweD
AW: KW in Datum umwandeln
07.10.2008 08:22:08
UweD
Hallo
der 01.01.2008 wäre falsch. Laut DIN ist es der 31.12.2007 der erste Tag in KW 01 in 2008
hier eine Lösung angepasst an deine Aufgabe (von www.excelformeln.de)
 
 ABC
108 / 01 41
2  2008
3   
431.12.2007 06.10.2008
5   
6  erstellt aus
Formeln der Tabelle
A4 : =DATUM((2000+LINKS(A1;2)); 1;7*RECHTS(A1;2)-3-WOCHENTAG(DATUM((2000+LINKS(A1;2)); ;); 3))
C4 : =DATUM(C2;1;7*C1-3-WOCHENTAG(DATUM(C2;;); 3))
 

Anzeige
AW: KW in Datum umwandeln
07.10.2008 09:17:00
Jochen
Danke UweD,
das ist besser.
AW: KW in Datum umwandeln
07.10.2008 08:55:47
Tino
Hallo,
so müsste es funktionieren.
 AB
108 / 0101.01.2008
208/0528.01.2008

Formeln der Tabelle
ZelleFormel
B1=WENN(JAHR(DATUM(LINKS(A1;2)+2000;1;7*RECHTS(A1;2)-3-WOCHENTAG(DATUM(LINKS(A1;2)+2000;; ); 3)))<LINKS(A1;2)+2000;DATUM(JAHR(DATUM(LINKS(A1;2)+2000;1;7*RECHTS(A1;2)-3-WOCHENTAG(DATUM(LINKS(A1;2)+2000;; ); 3)))+1;1;1); DATUM(LINKS(A1;2)+2000;1;7*RECHTS(A1;2)-3-WOCHENTAG(DATUM(LINKS(A1;2)+2000;; ); 3)))
B2=WENN(JAHR(DATUM(LINKS(A2;2)+2000;1;7*RECHTS(A2;2)-3-WOCHENTAG(DATUM(LINKS(A2;2)+2000;; ); 3)))<LINKS(A2;2)+2000;DATUM(JAHR(DATUM(LINKS(A2;2)+2000;1;7*RECHTS(A2;2)-3-WOCHENTAG(DATUM(LINKS(A2;2)+2000;; ); 3)))+1;1;1); DATUM(LINKS(A2;2)+2000;1;7*RECHTS(A2;2)-3-WOCHENTAG(DATUM(LINKS(A2;2)+2000;; ); 3)))

Gruß Tino
Anzeige

300 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige