Microsoft Excel

Herbers Excel/VBA-Archiv

USA Zahlenformat | Herbers Excel-Forum


Betrifft: USA Zahlenformat von: Silke
Geschrieben am: 15.10.2008 12:17:07

Liebe Leser,

ich muss in einer Kalkulation sowohl Zahlen im Euro Format 0.000,00
also auch im amerikanischen Format 0,000.00 anzeigen.
Über benutzerdefinierte Formate bekomme ich für letzteres aber nur 0,000 hin.
Wer kann mir helfen?

Vielen Dank

Silke

  

Betrifft: AW: USA Zahlenformat von: Harald Kapp
Geschrieben am: 15.10.2008 12:40:55

Hallo Silke,
ich fürchte das gelingt Dir nicht. Ob Punkt oder Komma als Dezimaltrennzeichen verwendet werden lässt sich nur global einstellen, nicht für jede Zelle einzeln.

Als Abhilfe fiele mir ein, eine Hilfsspalte zu machen, in der der Zahlenwert per Funktion (oder VBA) in einen entsprechend formatierten Textstring gewandlet und angezeigt wird.

Gruß Harald


  

Betrifft: AW: USA Zahlenformat -> Formeln von: Harald Kapp
Geschrieben am: 15.10.2008 13:12:52

Formelvorschlag (funktioniert bis 999.999,99, für größere Zahlen entsprechend zu erweitern):

Angenommen die zu formatierende Zahl steht in A2:

Deutsches Format:

=WENN(A2>=10^3;GANZZAHL(A2/1000)&"."&GANZZAHL(A2-1000*GANZZAHL(A2/1000)) &","&RUNDEN(100*(A2-GANZZAHL(A2));0);GANZZAHL(A2-1000*GANZZAHL(A2/1000)) &","&RUNDEN(100*(A2-GANZZAHL(A2));0))

Amerikanisches Format:
=WENN(A2>=10^3;GANZZAHL(A2/1000)&","&GANZZAHL(A2-1000*GANZZAHL(A2/1000)) &"."&RUNDEN(100*(A2-GANZZAHL(A2));0);GANZZAHL(A2-1000*GANZZAHL(A2/1000)) &"."&RUNDEN(100*(A2-GANZZAHL(A2));0))




Gruß Harald


  

Betrifft: geht kürzer. von: Rudi Maintaire
Geschrieben am: 15.10.2008 13:39:09

Hallo,
=WECHSELN(WECHSELN(TEXT(A2;"#|##0,00");",";".");"|";",")

Gruß
Rudi


  

Betrifft: AW: USA Zahlenformat von: Erich G.
Geschrieben am: 15.10.2008 13:54:59

Hallo Silke,
hier noch mal Haralds und Rudis Vorschlag (Spalten E und D) und noch zwei weitere in Spalten B und C:

 ABCDE
1Dt. FormatAm. Format 1Am. Format 2Am. Format 3Am. Format 4
20,120.120.12,0.120.12
31,231.231.23,1.231.23
4123,45123.45123.45,123.45123.45
51.111,001,111.001,111.001,111.001,111.0
6123.456,00123,456.00123,456.00123,456.00123,456.0
71.234.567,001,234,567.001,234,567.001234,567.001234,567.0
845.123.456,7845,123,456.7845,123,456.7845123,456.7845123,456.78
9345.123.456,78345,123,456.78345,123,456.78345123,456.78345123,456.78
102.345.123.456,782,345,123,456.782,345,123,456.782345123,456.782345123,456.78

Formeln der Tabelle
ZelleFormel
B2=WENN(A2<1;"0";TEXT(GANZZAHL(A2); RECHTS("#"",""###"",""###"",""##0";6*GANZZAHL(LOG(A2;1000))+1)))&"."&TEXT(100*(A2-GANZZAHL(A2)); "00")
C2=WECHSELN(WECHSELN(WECHSELN(TEXT(A2;"#.##0,00"); ",";"|"); ".";","); "|";".")
D2=WECHSELN(WECHSELN(TEXT(A2;"#|##0,00"); ",";"."); "|";",")
E2=WENN(A2>=10^3;GANZZAHL(A2/1000)&","&GANZZAHL(A2-1000*GANZZAHL(A2/1000)) &"."&RUNDEN(100*(A2-GANZZAHL(A2)); 0); GANZZAHL(A2-1000*GANZZAHL(A2/1000)) &"."&RUNDEN(100*(A2-GANZZAHL(A2)); 0))

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: USA Zahlenformat von: Silke
Geschrieben am: 22.10.2008 14:36:56

Lieber Harald, lieber Rudi, lieber Erich,

konnte leider erst heute wieder online gehen und bin überwältigt von Eurer schnellen und kompetenten Beratung!
Alle Ratschläge waren super, Rudi's Formel am einfachsten. Aber dann noch mal alles zusammengefasst in Tabellenform von Erich - was für ein Service.

Ein ganz dickes Dankeschön an alle

von Silke.


Beiträge aus den Excel-Beispielen zum Thema "USA Zahlenformat"