Microsoft Excel

Herbers Excel/VBA-Archiv

excel tabellen vergleichen? | Herbers Excel-Forum


Betrifft: excel tabellen vergleichen? von: thosrten1896
Geschrieben am: 20.10.2008 09:21:41

Hallo,
gibt es eine möglichkeit 2 excel tabellen auf gleichheit zu testen?

datei tabelle 1.xls
diff
datei tabelle 2 .xls

erg. unterschied der datei Tabellen.xls z.B. auf 2 wird der unterschied farblich markiert.

vielen Dank

  

Betrifft: AW: excel tabellen vergleichen? von: fcs
Geschrieben am: 20.10.2008 11:40:27

Hallo Thorsten,

du kannst in einem weiteren Tabellenblatt von Datei02.xls die Tabellen der beiden Dateien vergleichen.
z.B. Formel in A1:

=WENN(Tabelle1!A1=[Dateí01.xls]Tabelle1!A1;WAHR;FALSCH)


Diese Formel dann entsprechend dem Datenbereich in Tabelle1 nach unten und nach rechts kopieren.

Jetzt vergibst du für die Spalten mit den Daten in der Vergleichstabelle einen Bereichsnamen, z.B. Vergleich

In der Tabelle1 von Datei02.xls kannst du jetzt per bedingter Formatierung Unterschiede farblich kennzeichnen.
Markiere die Spalten mit den Daten beginnend mit Spalte A, dann bedingte Formatierung mit Formel:

=WENN(INDEX(Vergleich;ZEILE(A1);SPALTE(A1))=FALSCH;WAHR;FALSCH)


Alternativ könnte man die Kennzeichnung auch per Makro realisieren.

Gruß
Franz


Beiträge aus den Excel-Beispielen zum Thema "excel tabellen vergleichen?"