Microsoft Excel

Herbers Excel/VBA-Archiv

Wert in Tabelle suchen und summieren. | Herbers Excel-Forum


Betrifft: Wert in Tabelle suchen und summieren. von: cfrei75
Geschrieben am: 20.10.2008 18:14:12

Hallo ich habe ein Problem! Wer kann mir bitte helfen.

Beispiel:
A1=6 Uhr
B1=21 Uhr

In der Zeile 2 stehen die Uhrzeiten von 0 bis 24 Uhr (24 Werte) als Titel.
In der Zeile 3 stehen die Werte der einzelnen Uhrzeiten (24 Werte).

Ich bräuchte die Summe der Uhrzeitwerte zwischen 6 und 21 Uhr. Da A1 und B1 variabel sind kann ich nicht einfach eine Summe mit "Summe" bilden.

Ich bräuchte also eine Formel die die Uhrzeit (A1 und B1) in der Zeile 2 erkennt und dann die Summe mit den Werten der Zeile 3 ausgibt.

Ich danke Euch vielmals für Eure Unterstützung.

Viele Grüsse

Claus

  

Betrifft: AW: Bedingte Summe von: Erich G.
Geschrieben am: 20.10.2008 18:42:02

Hallo Claus,
zunächst eine kleine Korrektur:
In Zeile 2 stehen 24 Werte, von A2 bis X2: 0 Uhr bis 23 Uhr.
Damit gehts dann so:

 ABCDWX
106:0021:001832   
2      
300:0001:0002:0003:0022:0023:00
4101102103104123124

Formeln der Tabelle
ZelleFormel
C1=SUMMENPRODUKT((A3:X3>=A1)*(A3:X3<=B1)*A4:X4)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Bedingte Summe von: cfrei75
Geschrieben am: 21.10.2008 10:04:46

Hallo,

vielen Dank für deine Hilfe. Leider hat es nicht funktioniert . der Wert ist zu hoch. Ich habe mir auch die Hilfe von Summenprodukt angesehen und in dieser Funktion werden Werte multipliziert.

Wie heißt die Formel die ein Wert in einer Liste sucht und das Feld dazu ausgibt. Meine Ansich nach müsste es eine Summe Formel bei denen die dazugehörigen Zellen per suche eingetragen werden.

Die Formel muss halt in deinen Beispiel in der Zeile 3 nach der Nummer 6 und 21 suchen und die dazugehörige Zelle der Zeile 4 in der Summe Formel eintragen.


  

Betrifft: AW: Bedingte Summe von: Erich G.
Geschrieben am: 21.10.2008 11:59:54

Hallo Claus,
ich denke schon, dass SUMMENPRODUKT hier richtig rechnet.
Lag es vielleicht daran, dass man bei meinem vorigen Beispiel die (auch gefüllten) Spalten E bis V nicht sehen konnte?

Prüf das bitte noch mal am folgenden Beispiel.
Da werden die Zahlen unter den Uhrzeiten 06:00 bis 08:00 addiert,
in C1 mit der Summenprodukt-Formel, in E1 mit einer fixen SUMME (nur zum Nachrechnen):

 ABCDEFGHIJ
106:0008:00324 324     
2          
300:0001:0002:0003:0004:0005:0006:0007:0008:0009:00
4101102103104105106107108109110

Formeln der Tabelle
ZelleFormel
C1=SUMMENPRODUKT((A3:X3>=A1)*(A3:X3<=B1)*A4:X4)
E1=SUMME(G4:I4)

Hier auch noch eine Mappe zum Spielen: https://www.herber.de/bbs/user/56161.xls

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: SUMMENPRODUKT von: Erich G.
Geschrieben am: 21.10.2008 16:04:19

Hallo Claus,
wenn du genauer sehen möchtest, wie SUMMENPRODUKT mit Wahrheitswerten arbeitet,
schau mal hier: http://www.online-excel.de/excel/singsel.php?f=53

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


Beiträge aus den Excel-Beispielen zum Thema "Wert in Tabelle suchen und summieren."