Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema RefEdit
BildScreenshot zu RefEdit RefEdit-Seite mit Beispielarbeitsmappe aufrufen

Summe über Bereich | Herbers Excel-Forum


Betrifft: Summe über Bereich von: harald
Geschrieben am: 21.10.2008 13:41:41

Hallo,
ich habe über mehrere Zeilen (z.B. B7 bis B36) eine Summe ermittelt und in B40 eingetragen mit der Formel
=SUMME(B7:B36).
Nun möchte ich diese Formel so abändern, dass die Summe von B7*C7 bis B36*C36 ermittelt wird. Wie geht das? Hintergrund ist, dass ich nur dann den Wert von B hinzufügen möchte, wenn C nicht leer ist.
Im voraus vielen Dank
mfg
harald

  

Betrifft: AW: Summe über Bereich von: WalterK
Geschrieben am: 21.10.2008 13:48:59

Hallo,

hier mal 2 Möglichkeiten:
Tabelle1

 BC
414 
514 
6  
71A
82 
93B
104A
115 
126C

Formeln der Tabelle
ZelleFormel
B4{=SUMME(WENN(C7:C12<>"";B7:B12))}
B5=SUMMENPRODUKT((C7:C12<>"")*B7:B12)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Servus, Walter


  

Betrifft: AW: Summe über Bereich von: harald
Geschrieben am: 21.10.2008 14:11:15

Hallo Walter,
vielen Dank für die schnelle Hilfe! Die zweite Formel funktioniert, mit der ersten habe ich Probleme - wenn ich sie so übernehme, erscheint nur die Formel, aber nicht der Wert in der Zelle, wenn ich die geschweiften Klammern weglasse, erscheint der Ausdruck WERT!
Aber mit der zweiten Formel kann ich weiterarbeiten.

m.f.g.
harald


  

Betrifft: AW: Summe über Bereich von: Reinhard
Geschrieben am: 21.10.2008 14:13:35

Hi Harald,

steht doch da:

Umrandende { } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!

und/oder klick mal auf "Matrix verstehen" in Walters Antwort.

Gruß
Reinhard


  

Betrifft: AW: Summe über Bereich von: harald
Geschrieben am: 21.10.2008 14:47:07

stimmt - so klappt es auch mit der ersten Formel - vielen Dank

m.f.g.
harald


Beiträge aus den Excel-Beispielen zum Thema "Summe über Bereich"