Microsoft Excel

Herbers Excel/VBA-Archiv

Monatsende und gleichzeitig Arbeitstag | Herbers Excel-Forum


Betrifft: Monatsende und gleichzeitig Arbeitstag von: Bernd
Geschrieben am: 23.10.2008 15:41:54

Hallo zusammen,

ich würde gerne von einem Datum ausgehend, den letzten Tag des Vormonat bestimmen, der zugleich auch noch ein Arbeitstag (Montag-Freitag) war.

Wie geht das?

Gruß
Bernd

  

Betrifft: AW: Monatsende und gleichzeitig Arbeitstag von: Ptonka
Geschrieben am: 23.10.2008 16:05:50

HalloBernd,

angenommen in A2 steht Dein Ausgangsdatum, dann schreib in A1 folgendes:

=WENN(WOCHENTAG(MONATSENDE(A2;-1))=1;(MONATSENDE(A2;-1)-2);WENN(WOCHENTAG(MONATSENDE(A2;-1))=7; (MONATSENDE(A2;-1)-1);MONATSENDE(A2;-1)))

Gruß,
Ptonka


  

Betrifft: AW: Monatsende und gleichzeitig Arbeitstag von: rlenz
Geschrieben am: 23.10.2008 17:00:54

Hallo Bernd,
vielleicht so?
Tabelle1

 ABCD
1mit Add-In Analyse-Funktion
2letzter Arbeitstag Vormonatletzter Arbeitstag Vormonat mit sonstigen freien TageAusgangs datumListe sonstige freie Tage
329.08.200828.08.200810.09.200801.01.2008
429.08.200828.08.200810.09.200829.08.2008
5   25.12.2008
6    
7    
8ohne Add-In Analyse-Funktion  
9letzter Arbeitstag VormonatAusgangs datum  
1029.08.200810.09.2008  
1129.08.200810.09.2008  

Formeln der Tabelle
ZelleFormel
A3=ARBEITSTAG(MONATSENDE(C3;-1); -1)
B3=ARBEITSTAG(MONATSENDE(C3;-1); -1;$D$3:$D$6)
A4=WENN(ISTZAHL(C4); ARBEITSTAG(MONATSENDE(C4;-1); -1); "")
B4=WENN(ISTZAHL(C4); ARBEITSTAG(MONATSENDE(C4;-1); -1;$D$3:$D$6); "")
A10=WENN(WOCHENTAG(DATUM(JAHR(B10); MONAT(B10); 0); 2)=6;DATUM(JAHR(B2); MONAT(B10); 0)-1;WENN(WOCHENTAG(DATUM(JAHR(B10); MONAT(B10); 0); 2)=7;DATUM(JAHR(B10); MONAT(B10); 0)-2;""))
A11=WENN(ISTZAHL(B11); WENN(WOCHENTAG(DATUM(JAHR(B11); MONAT(B11); 0); 2)=6;DATUM(JAHR(B3); MONAT(B11); 0)-1;WENN(WOCHENTAG(DATUM(JAHR(B11); MONAT(B11); 0); 2)=7;DATUM(JAHR(B11); MONAT(B11); 0)-2;"")); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

MfG
Rüdiger Lenz


  

Betrifft: AW: Monatsende und gleichzeitig Arbeitstag von: rlenz
Geschrieben am: 23.10.2008 18:01:28

Hallo Bernd,
Leider war es vorher fehlerhaft. Ich hoffe, es ist nun richtig.
Tabelle1

 ABCD
1mit Add-In Analyse-Funktion
2letzter Arbeitstag Vormonatletzter Arbeitstag Vormonat mit sonstigen freien TageAusgangs datumListe sonstige freie Tage
331.07.200830.07.200804.08.200801.01.2008
429.08.200828.08.200810.09.200829.08.2008
5   25.12.2008
6   31.07.2008
7    
8ohne Add-In Analyse-Funktion  
9letzter Arbeitstag VormonatAusgangs datum  
1031.07.200804.08.2008  
1129.08.200810.09.2008  

Formeln der Tabelle
ZelleFormel
A3=ARBEITSTAG(MONATSENDE(C3;-1)+1;-1)
B3=ARBEITSTAG(MONATSENDE(C3;-1)+1;-1;$D$3:$D$6)
A4=WENN(ISTZAHL(B4); ARBEITSTAG(MONATSENDE(C4;-1)+1;-1); "")
B4=WENN(ISTZAHL(C4); ARBEITSTAG(MONATSENDE(C4;-1)+1;-1;$D$3:$D$6); "")
A10=WENN(WOCHENTAG(DATUM(JAHR(B10); MONAT(B10); 0); 2)=7;DATUM(JAHR(B10); MONAT(B10); 0)-2;WENN(WOCHENTAG(DATUM(JAHR(B10); MONAT(B10); 0); 2)=6;DATUM(JAHR(B10); MONAT(B10); 0)-1;DATUM(JAHR(B10); MONAT(B10); 0)))
A11=WENN(ISTZAHL(B11); WENN(WOCHENTAG(DATUM(JAHR(B11); MONAT(B11); 0); 2)=7;DATUM(JAHR(B11); MONAT(B11); 0)-2;WENN(WOCHENTAG(DATUM(JAHR(B11); MONAT(B11); 0); 2)=6;DATUM(JAHR(B11); MONAT(B11); 0)-1;DATUM(JAHR(B11); MONAT(B11); 0))); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

MfG
Rüdiger Lenz


  

Betrifft: geht um einiges kürzer von: WF
Geschrieben am: 23.10.2008 18:18:33

Hi Bernd,

=DATUM(JAHR(A1);MONAT(A1);)-MAX(;WOCHENTAG(DATUM(JAHR(A1);MONAT(A1););2)-5)

Salut WF


  

Betrifft: Besten Dank Euch allen, nun Qual der Wahl! von: Bernd
Geschrieben am: 23.10.2008 20:03:56




  

Betrifft: egal, was Du wählst, aber ..... von: WF
Geschrieben am: 23.10.2008 20:38:37

..... benutze NIEMALS ein Add-In.

Hi Bernd,

kann Ich Dir (leider aus Erfahrung) nur raten !!!!
Gibst Du Deine Tabelle an jemanden weiter und dieser hat die Analysefunktionen nicht geladen, erhält er Fehlermeldungen.
Und ebenso auch, wenn die Analysefunktionen geladen sind, sind diese Add-Ins mal in englisch und mal in deutsch - versionsunabhängig ?

Salut WF


Beiträge aus den Excel-Beispielen zum Thema "Monatsende und gleichzeitig Arbeitstag"