KALENDER | Herbers Excel-Forum


Betrifft: KALENDER
von: Meyburg
Geschrieben am: 18.12.2008 15:24:15

Hallo Excelfreunde,
in eine Exceltabelle möchte ich einen kleinen Monats-Kalender einfügen. Die Wochentage sollen als Überschrift statisch sein. Das Datum soll den Wochentagen automatsch zugeordnet werden.
etwa so:


Mo  Di  Mi  Do  Fr  Sa  So    obere Reihe (Tage) soll immer unverändert bleiben!
        01  02 03  04  05    Datum soll den TAGEN zugeordnet werden!
06  07 08  09 10  11 usw.



Ich kenne zwar den Begriff Monatsende -


 Formelbeispiel: =WENN($AA$32+3>MONATSENDE($AA$5;0);"";DATUM($AA$2;$AA$3;Z35))



Wie aber bekomme ich es mit dem Monatsbeginn hin und ordne das Datum dem statischen Tag zu?

Ich wäre Dankbar für Hilfe!

Habe mich schon wieder irgendwie festgebastelt und weiß nicht mehr weiter.

vorweihnachtliche Grüße
aus Ostfriesland

Frank Meyburg

Betrifft: AW: KALENDER
von: fcs
Geschrieben am: 18.12.2008 16:08:01
Hallo Frank,
da mehrer unterschiedliche Formeln erfoderlich sind hier eine kleine Beispieldatei
https://www.herber.de/bbs/user/57715.xls
Gruß
Franz

Betrifft: AW: KALENDER
von: Uwe (:o)
Geschrieben am: 18.12.2008 16:28:50
Hi Frank,
ich habe auch mal ein bisschen gebastelt, die Formel sind etwas anders als bei Franz, aber es sollte auch klappen. Auch bei mir der 1. des Monats in A1.
https://www.herber.de/bbs/user/57716.xls
Gruß
Uwe
(:o)

Betrifft: AW: KALENDER
von: Erich G.
Geschrieben am: 18.12.2008 17:05:26
Hallo Frank,
und noch ein Vorschlag. Ich hoffe, die Formeln sind alle im grünen Bereich
(außerhalb werden keine gebraucht. ;-))
https://www.herber.de/bbs/user/57717.xls
Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort

Betrifft: AW: KALENDER - etwas kürzere Formeln
von: Erich G.
Geschrieben am: 18.12.2008 17:14:51
Hallo nochmal,
mit TAG statt MONAT gehts auch noch etwas kürzer:
https://www.herber.de/bbs/user/57718.xls
Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort

Betrifft: AW: KALENDER
von: Meyburg
Geschrieben am: 19.12.2008 10:07:17
Hallo und DANKE!
funktioniert alles wunderbar.
Habe alles mal ausprobiert, bin bei der Formel mit "Wochentag" von Uwe zunächst nicht auf die formatierung der Tage Mo - So gekommen, dann hat es aber auch dort geklappt.
Danke für die Lösungsmöglichkeiten
ein schönes Wochenende
Frank

Betrifft: AW: KALENDER
von: Meyburg
Geschrieben am: 19.12.2008 12:10:57
HALLO ich bin's nochmal!
Ich habe mich nochmal umentschieden und die Kalenderversion von Uwe in meine
Mappe eingebaut. In meiner Mappe habe ich außerdem einen Bereich der heißt "Frei", in dem sind alle Feiertage aufgelistet, die mit Formeln usw. sich automatisch dem Jahr entsprechend anpassen. Jetzt möchte ich gerne in den eingebauten Monatskalender von Uwe mit Hilfe der bedingten Formatierung bespielsweise einen Feiertag farblich hervorheben. Ich weiß nicht so recht wie ich es angehen soll!
Auf Hilfe bin ich wiedermal angewiesen!
Danke im Voraus
Gruß Frank

Betrifft: AW: KALENDER
von: Uwe (:o)
Geschrieben am: 19.12.2008 14:08:40
Hi Frank,
das:
https://www.herber.de/bbs/user/57743.xls
müsste Dir eigentlich weiterhelfen.
Gruß
Uwe
(:o)

Betrifft: AW: KALENDER
von: fcs
Geschrieben am: 19.12.2008 18:12:08
Hallo Frank,
Formel für Bedingte Formatierung Zelle A3:


=WENN(ISTFEHLER(SVERWEIS(A3;Frei;1;FALSCH));FALSCH;WAHR)


Gruß
Franz

Betrifft: AW: KALENDER
von: Uwe (:o)
Geschrieben am: 19.12.2008 19:51:14
Hi Franz,
das WENN ist da aber, denke ich, überflüssig, oder?:


=NICHT(ISTNV(VERGLEICH(A3;Frei;0)))


Geht natürlich entsprechend mit SVERWEIS auch.
Gruß
Uwe
(:o)

Betrifft: AW: KALENDER
von: Meyburg
Geschrieben am: 22.12.2008 10:20:29
Hallo!
Ich möchte mich bei Euch bedanken, Funktion ist einwandfrei!
Schönes Weihnachtsfest
und nen Guten Rutsch
Frank

Beiträge aus den Excel-Beispielen zum Thema "KALENDER"