Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Listenauswertung per Formel

Listenauswertung per Formel
03.02.2009 17:29:00
Sebastian
Hallo allerseits!
Ich habe folgendes Problem, daß ich ohne ein Makro/VBA also nur durch Formeln in der jeweiligen Zelle lösen möchte:
Folgende Tabelle ist gegeben:
-------A----------B----------C-------
1----(leer)----Auto 1-----Auto 2---
2--NUMMER--BETRAG--BETRAG--
2----1111------0,00------1,50-----
3----2222------1,75------0,00-----
4----3333------0,25------1,00-----
5----4444------0,00------0,00-----
--------------------------------------------
SUMME:--------2,00------2,50-----
Die Auswertung soll nun in einem anderen Tabellenblatt stattfinden. Dabei soll Excel soll mir nun in eine vorgefertigte Tabelle folgende Informationen schreiben:
Für Auto 1
--------------
NUMMER---------------------BETRAG
2222 (durch Excel)-----------1,75 (durch Excel)
3333 (durch Excel)-----------0,25 (durch Excel)
Was soll also passieren:
Ich möchte nur ein einziges Eingabefeld haben, ich welches ich "Auto 1" oder "Auto 2" eintippen muß, und Excel listet mir danach unter NUMMER und BETRAG jeweils die Nummern auf, die im Betrag NICHT 0,00 sind - schließlich fügt Excel dann noch den jeweiligen Betrag daneben auf.
Problematisch ist für mich bisher nur die Erstellung der Liste mit den entsprechenden Nummern, den Betrag kann ich ja einfach via SVERWEIS zuschlüsseln.
Hat jemand eine Idee? Für Hilfe wäre ich SEHR dankbar, da ich mittlerweile am verzweifeln bin...
Gruß,
Sebastian

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Listenauswertung per Formel
03.02.2009 17:51:06
Josef
Hallo Sebastian,
Tabelle3

 ABCDEFG
1 Auto 1Auto 2 Auto 1  
2NUMMERBETRAGBETRAG NUMMERBETRAG 
3111101,5 22221,75 
422221,750 33330,25 
533330,251    
6444400    
7       
8SUMME:22,5    
9       
10       

Formeln der Tabelle
ZelleFormel
E3{=WENN(ZÄHLENWENN(car_;"<>0")<ZEILE(A1); "";KKLEINSTE(WENN(car_<>0;$A$3:$A$6); ZEILE(A1)))}
F3=WENN(E3<>"";INDEX(car_;VERGLEICH(E3;$A$3:$A$6;0)); "")
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen
Namen in Formeln
ZelleNameBezieht sich auf
E3car_=BEREICH.VERSCHIEBEN(Tabelle3!$A$1;2;VERGLEICH(Tabelle3!$E$1;Tabelle3!$1:$1;0)-1;4)
F3car_=BEREICH.VERSCHIEBEN(Tabelle3!$A$1;2;VERGLEICH(Tabelle3!$E$1;Tabelle3!$1:$1;0)-1;4)
Namen verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp

Anzeige
AW: Listenauswertung per Formel
03.02.2009 18:12:10
Sebastian
Super, vielen Dank!!!
Werd's gleich ausprobieren!
Viele Grüße

343 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige