Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zahlenpaare ermitteln

Zahlenpaare ermitteln
28.02.2009 01:57:47
Thomas
Hallo,
ist ein bissl schwer zu beschreiben was ich möchte, aber ich versuche es mal.
Ich habe in der Spalte D mehrere Zahlenpaare. In der ersten Zeile (ungerade) steht immer die erste Zahl, die dazu gehörige Zahl ist in der darauf folgenden Zeile (gerade). Jetzt suche ich den K-Grössten Wert (von 1 bis 5) der ersten Zahlen, dieser soll in der Spalte F ausgegeneben werden. Die dazu gehörige Zahl soll dann darunter ausgegeben werden. Wie kann ich das erreichen?
Als nächstes möchte ich die Anzahl der ersten Zahlen, die dem K-Grössten Wert entsprechen, wisssen.
Bsp:
D1 = 15
D2 = 3
D3 = 7
D4 = 15
D5 = 8
D6 = 6
D7 = 15
D8 = 3
D9 = 12
D10 = 7
Die Zahlen in D1 und D2 ergeben ein Paar, D3 und D4...usw.
Mit F1 = KGRÖSSTE((D1;D3;D5;D7;D9);1) ermittle ich die größte Zahl in ungeraden Zellen.
Wie bekomme ich in F2 dann zu der größten Zahl das passende Zahlenpaar?
Also so soll es dann aussehen:
F1 = 15
? F2 = 3
F3 = 12
? F4 = 7
F5 = 8
? F6 = 6
F7 = 7
? F8 = 15
F9 = ""
? F10 = ""
Sollte das funktionieren soll, gezählt werden wie oft die erste Zahl vorkommt. Da aber der Wert auch in der zweiten Zahl vorkommen kann, aber nicht mitgezählt werden soll, ist G1 = Zählenwenn(D1:D10;F1) nicht möglich. Wie kann ich dennoch die Anzahl der ersten Zahlen ermitteln? Das Ergebnis soll jeweils in der Spalte G in einer ungeraden Zeile stehen.
G1 = 2
G3 = 1
G5 = 1
G7 = 1
G9 = ""
Hm, kann das einer verstehen was ich eigendlich will und hat dann auch noch einen Lösungsvorschlag?
Ich lass mich überraschen...
Vielen Dank an Alle, die sich Zeit nehmen Anderen und mir zu helfen.
Gruß, Thomas

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zahlenpaare ermitteln
28.02.2009 02:44:29
Daniel
Hi
wenn du die erste Zahl gefunden hast, dann bekommst du die zweite Zahl mit der Formel:
=index(D:D;Vergleich(Formel für erste Zahl;D:D;0)+1)


die Häufigkeit der ersten Zahl in den ungeraden Zeilen bekommst du mit dieser Formel:


=SUMMENPRODUKT(1*(D1:D10=Formel für erste Zahl);1*(REST(ZEILE(D1:D10);2)=1))


für Formel für erste Zahl musst du natürlich noch die passende KGRÖSSTE-Formel oder den entsprechenden Zellbezug noch einsetzen
Gruß, Daniel

AW: Zahlenpaare ermitteln
28.02.2009 12:56:41
Thomas
Hallo,
mit der ersten Formel erhalte ich das gewünschte Ergebnis. Super, bei der zweiten ist das Ergebnis dann aber 0. Das haut noch nicht so hin.
Vielen Dank.
Gruß Thomas
Anzeige
AW: Zahlenpaare ermitteln
28.02.2009 08:49:59
Josef
Hallo Thomas,
meinst du so?
Tabelle1

 CDEFGH
1 15 152 
2 3 32 
3 7 152 
4 15 32 
5 8 121 
6 6 71 
7 15 81 
8 3 61 
9 12 71 
10 7 151 
11      
12      
13      

Formeln der Tabelle
ZelleFormel
F1{=KGRÖSSTE(WENN(REST(ZEILE($1:$10); 2)=1;$D$1:$D$10+ZEILE($1:$10)*10^-15); GANZZAHL((ZEILE(A1)-1)/2)+1)}
G1{=SUMME(WENN(($D$1:$D$10=GANZZAHL(F1))*(REST(ZEILE($1:$10); 2)=REST(ZEILE(A1); 2)); 1))}
F2{=INDEX($D$1:$D$10;VERGLEICH(F1;$D$1:$D$10+ZEILE($1:$10)*10^-15;0)+1)}
G2{=SUMME(WENN(($D$1:$D$10=GANZZAHL(F2))*(REST(ZEILE($1:$10); 2)=REST(ZEILE(A2); 2)); 1))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp

Anzeige
AW: Zahlenpaare ermitteln
28.02.2009 12:55:04
Thomas
Hallo,
gemeint habe ich das fast so. Das Paar 15 und 3 kommt jetzt 2x vor, soll aber nur einmal dort stehen. Dennoch bekomm ich die Formel nicht angepaßt und kanns leider nicht umsetzten. Mit der Antwort von Daniel kann ich doch mehr anfangen.
Trotzdem vielen Dank.
Gruß Thomas
Habs jetz doch geschnallt..
28.02.2009 13:01:12
Thomas
.. und alles läuft bestens!
Super.
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige
Archiv - Verwandte Themen
Forumthread
Beiträge