Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Schleife mit WENN, DANN
05.04.2009 10:32:59
Mandy
Hi,
wie kann ich denn eine Schleife machen die die Spalte duchläuft und überprüft:
Wenn B5 und C5 nicht leer ist, dann A5 = "100" `Startwert
Wenn B6 und C6 nicht leer ist, dann A5 * 1,25
Wenn B7 und C7 nicht leer ist, dann A6 * 1,25
Wenn B8 und C8 nicht leer ist, dann A8 * 1,25 'usw.
Danke und Gruss
Mandy

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Schleife mit WENN, DANN
05.04.2009 10:40:50
Hajo_Zi
Hallo Mandy,
Tabelle2

 BCD
11  
21  
3   
412100
536125

Formeln der Tabelle
ZelleFormel
D1=WENN(UND(C1<>"";B1<>""); 100;"")
D2=WENN(UND(C2<>"";B2<>""); WENN(MAX($D$1:D1)>=100;MAX($D$1:D1)*1,25;100); "")
D3=WENN(UND(C3<>"";B3<>""); WENN(MAX($D$1:D2)>=100;MAX($D$1:D2)*1,25;100); "")
D4=WENN(UND(C4<>"";B4<>""); WENN(MAX($D$1:D3)>=100;MAX($D$1:D3)*1,25;100); "")
D5=WENN(UND(C5<>"";B5<>""); WENN(MAX($D$1:D4)>=100;MAX($D$1:D4)*1,25;100); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Anzeige
Danke, hast Du das auch als Makro (Schleife) :-)
05.04.2009 10:46:29
Mandy
AW: VBA Werte eintragen
05.04.2009 13:39:56
Hajo_Zi
Hallo Mandy,
man sollte im Beitrag schon schreiben das man Wert aufg eine VBA Lösung legt. Dann hättte man sich die Zeit zur Erstellung einer Formellösung sparen können. Bei einer VBA Lösung muss die Aufgabe schon 100% klar sein. Was Mir bei Deiner Aufgabe nicht klar zu sein scheint. Ich hae jetzt viele Sachen angenommen. Falls es nicht stimmt mußt Du es selber lösen. Ich habe jetzt schon Zeit in 2 Lösungen gesteckt.
Option Explicit Private Sub Worksheet_Change(ByVal Target As Range) If Target.Count = 1 Then If Target.Column = 2 Or Target.Column = 3 Then If Cells(Target.Row, 2) "" And Cells(Target.Row, 3) "" Then Application.EnableEvents = False If Target.Row = 1 Then Cells(Target.Row, 4) = 100 Else If Application.WorksheetFunction.Max(Range(Cells(1, 4), Cells(Target.Row - _ 1, 4))) = 0 Then Cells(Target.Row, 4) = 100 Else Cells(Target.Row, 4) = Application.WorksheetFunction.Max(Range(Cells(1, _ 4), Cells(Target.Row - 1, 4))) * 1.25 End If End If Application.EnableEvents = True End If End If End If End Sub


Gruß Hajo

Anzeige
Ich werds beste draus machen, Danke
05.04.2009 16:45:41
Mandy

316 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige