Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Monatstage eines Zeitraums auflisten

Monatstage eines Zeitraums auflisten
13.04.2009 15:52:33
Gerhard
Hallo zusammen,
in einer Tabelle möchte ich zu verschiedenen Anfangs- und Enddatums (-tümer?) die Anzahl der relevanten Tage je Monat berechnen. Wer kann mir bitte die Formeln anpassen? Die Lösung für nur einen Zeitraum in eine Zeile habe ich bereits gefunden, aber die Anpassung auf mehrere Zeilen gelingt mir nicht.
Gruß
Gerhard E.
Meine Tabelle:
https://www.herber.de/bbs/user/61168.xls

13
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Monatstage eines Zeitraums auflisten
13.04.2009 16:27:28
Gerhard
Hallo Gerd,
dieses Excelformeln-Beispiel 437 habe ich bereits umgesetzt, aber es funktioniert in dieser Form nur für ein Datumspaar. Mehrere Zeilen mit Anfangs- u. Enddatum zu bearbeiten gelingt mir nicht. (Siehe meine Beispieltabelle).
Gruß
Gerhard E.
AW: Monatstage eines Zeitraums auflisten
13.04.2009 17:16:58
Odje.K
Hallo Gerhard,
siehe mal hier:
www.exceldaily.de/excel-listen/artikel/d/monatstage-eines-zeitraums-auflisten.html
Gruß
Odje
AW: Monatstage eines Zeitraums auflisten
13.04.2009 17:44:13
Gerhard
Hallo Odje,
danke. Dieses Beispiel ist identisch mit
http://www.excelformeln.de/formeln.html?welcher=437
und gilt nur für für eine Zeile. Die Formeln kann man nicht nach unten kopieren weil die Spaltenüberschriften jeweils abhängig aus dem Datum erzeugt wird.
Ich muss eine Vielzahl von Zeiträumen in einer Liste bearbeiten und die Tage auf Monate verteilen.
Meine Liste sieht so aus:
https://www.herber.de/bbs/user/61168.xls
Vielleicht gibts doch Formeln die in Spalten nach unten kopiert werden können?
Gruß
Gerhard E.
Anzeige
AW: Monatstage eines Zeitraums auflisten
13.04.2009 18:49:05
Gerhard
Hallo Robert,
danke, sieht gut aus, nur in den Spalten Januar (wenn kein Datum eingetragen) und Dezember (immer der Wert 1)gibts noch Probleme.
Werd mich daran weiterversuchen...
Gruß
Gerhard E.
AW: Monatstage eines Zeitraums auflisten
13.04.2009 19:08:12
robert
hi,
das mit jänner versteh ich nicht, um dezember richtig zu rechnen, eine spalte mit 1.1.2009
anhängen
gruß
robert
AW: Monatstage eines Zeitraums auflisten
13.04.2009 20:05:32
Gerhard
Hallo Robert,
so gehts, danke nochmals.
Gerhard
AW: Danke f.Rückmeldung owT
14.04.2009 09:01:45
robert
hier mal neu strukturiert ...
13.04.2009 18:25:32
Matthias
Hallo Gerhard
In dieser Struktur kannst Du nicht nach unten kopieren, jedenfalls nicht ohne kleine Änderungen.
mal anhand Deiner Orginaldatei.
Userbild


hier die Datei
https://www.herber.de/bbs/user/61174.xls


und so sollte es später aussehen:
Userbild
Gruß Matthias
Anzeige
AW: hier mal neu strukturiert ...
13.04.2009 18:53:44
Gerhard
Hallo Mathias,
danke für die Hinweise und deine Fleißarbeit. Nur schade dass dabei die Monatszahlen nicht untereinander stehen können...
Gruß
Gerhard
AW: Monatstage eines Zeitraums auflisten
13.04.2009 18:54:53
Gerd
Hallo Gerhard,
eine Ziehformel. Bestimmt geht 's noch einfacher :-)
Tabelle1

 ABCDEFGHIJKLMNOP
1  01.01.200701.02.200701.03.200701.04.200701.05.200701.06.200701.07.200701.08.200701.09.200701.10.200701.11.200701.12.200701.01.200801.02.2008
2  31.01.200728.02.200731.03.200730.04.200731.05.200730.06.200731.07.200731.08.200730.09.200731.10.200730.11.200731.12.200731.01.200829.02.2008
3VonBis              
415.05.200720.05.2007    6         
515.09.200720.02.2008        163130313120
620.07.200710.08.2007      1210      
701.02.200713.05.2007 28313013         
8                

Formeln der Tabelle
ZelleFormel
C4=WENN(ODER($B4<C$1;$A4>C$2); "";MIN(C$2;$B4)-MAX(C$1;$A4)+1)
D4=WENN(ODER($B4<D$1;$A4>D$2); "";MIN(D$2;$B4)-MAX(D$1;$A4)+1)
E4=WENN(ODER($B4<E$1;$A4>E$2); "";MIN(E$2;$B4)-MAX(E$1;$A4)+1)
F4=WENN(ODER($B4<F$1;$A4>F$2); "";MIN(F$2;$B4)-MAX(F$1;$A4)+1)
G4=WENN(ODER($B4<G$1;$A4>G$2); "";MIN(G$2;$B4)-MAX(G$1;$A4)+1)
H4=WENN(ODER($B4<H$1;$A4>H$2); "";MIN(H$2;$B4)-MAX(H$1;$A4)+1)
I4=WENN(ODER($B4<I$1;$A4>I$2); "";MIN(I$2;$B4)-MAX(I$1;$A4)+1)
J4=WENN(ODER($B4<J$1;$A4>J$2); "";MIN(J$2;$B4)-MAX(J$1;$A4)+1)
K4=WENN(ODER($B4<K$1;$A4>K$2); "";MIN(K$2;$B4)-MAX(K$1;$A4)+1)
L4=WENN(ODER($B4<L$1;$A4>L$2); "";MIN(L$2;$B4)-MAX(L$1;$A4)+1)
M4=WENN(ODER($B4<M$1;$A4>M$2); "";MIN(M$2;$B4)-MAX(M$1;$A4)+1)
N4=WENN(ODER($B4<N$1;$A4>N$2); "";MIN(N$2;$B4)-MAX(N$1;$A4)+1)
O4=WENN(ODER($B4<O$1;$A4>O$2); "";MIN(O$2;$B4)-MAX(O$1;$A4)+1)
P4=WENN(ODER($B4<P$1;$A4>P$2); "";MIN(P$2;$B4)-MAX(P$1;$A4)+1)
C5=WENN(ODER($B5<C$1;$A5>C$2); "";MIN(C$2;$B5)-MAX(C$1;$A5)+1)
D5=WENN(ODER($B5<D$1;$A5>D$2); "";MIN(D$2;$B5)-MAX(D$1;$A5)+1)
E5=WENN(ODER($B5<E$1;$A5>E$2); "";MIN(E$2;$B5)-MAX(E$1;$A5)+1)
F5=WENN(ODER($B5<F$1;$A5>F$2); "";MIN(F$2;$B5)-MAX(F$1;$A5)+1)
G5=WENN(ODER($B5<G$1;$A5>G$2); "";MIN(G$2;$B5)-MAX(G$1;$A5)+1)
H5=WENN(ODER($B5<H$1;$A5>H$2); "";MIN(H$2;$B5)-MAX(H$1;$A5)+1)
I5=WENN(ODER($B5<I$1;$A5>I$2); "";MIN(I$2;$B5)-MAX(I$1;$A5)+1)
J5=WENN(ODER($B5<J$1;$A5>J$2); "";MIN(J$2;$B5)-MAX(J$1;$A5)+1)
K5=WENN(ODER($B5<K$1;$A5>K$2); "";MIN(K$2;$B5)-MAX(K$1;$A5)+1)
L5=WENN(ODER($B5<L$1;$A5>L$2); "";MIN(L$2;$B5)-MAX(L$1;$A5)+1)
M5=WENN(ODER($B5<M$1;$A5>M$2); "";MIN(M$2;$B5)-MAX(M$1;$A5)+1)
N5=WENN(ODER($B5<N$1;$A5>N$2); "";MIN(N$2;$B5)-MAX(N$1;$A5)+1)
O5=WENN(ODER($B5<O$1;$A5>O$2); "";MIN(O$2;$B5)-MAX(O$1;$A5)+1)
P5=WENN(ODER($B5<P$1;$A5>P$2); "";MIN(P$2;$B5)-MAX(P$1;$A5)+1)
C6=WENN(ODER($B6<C$1;$A6>C$2); "";MIN(C$2;$B6)-MAX(C$1;$A6)+1)
D6=WENN(ODER($B6<D$1;$A6>D$2); "";MIN(D$2;$B6)-MAX(D$1;$A6)+1)
E6=WENN(ODER($B6<E$1;$A6>E$2); "";MIN(E$2;$B6)-MAX(E$1;$A6)+1)
F6=WENN(ODER($B6<F$1;$A6>F$2); "";MIN(F$2;$B6)-MAX(F$1;$A6)+1)
G6=WENN(ODER($B6<G$1;$A6>G$2); "";MIN(G$2;$B6)-MAX(G$1;$A6)+1)
H6=WENN(ODER($B6<H$1;$A6>H$2); "";MIN(H$2;$B6)-MAX(H$1;$A6)+1)
I6=WENN(ODER($B6<I$1;$A6>I$2); "";MIN(I$2;$B6)-MAX(I$1;$A6)+1)
J6=WENN(ODER($B6<J$1;$A6>J$2); "";MIN(J$2;$B6)-MAX(J$1;$A6)+1)
K6=WENN(ODER($B6<K$1;$A6>K$2); "";MIN(K$2;$B6)-MAX(K$1;$A6)+1)
L6=WENN(ODER($B6<L$1;$A6>L$2); "";MIN(L$2;$B6)-MAX(L$1;$A6)+1)
M6=WENN(ODER($B6<M$1;$A6>M$2); "";MIN(M$2;$B6)-MAX(M$1;$A6)+1)
N6=WENN(ODER($B6<N$1;$A6>N$2); "";MIN(N$2;$B6)-MAX(N$1;$A6)+1)
O6=WENN(ODER($B6<O$1;$A6>O$2); "";MIN(O$2;$B6)-MAX(O$1;$A6)+1)
P6=WENN(ODER($B6<P$1;$A6>P$2); "";MIN(P$2;$B6)-MAX(P$1;$A6)+1)
C7=WENN(ODER($B7<C$1;$A7>C$2); "";MIN(C$2;$B7)-MAX(C$1;$A7)+1)
D7=WENN(ODER($B7<D$1;$A7>D$2); "";MIN(D$2;$B7)-MAX(D$1;$A7)+1)
E7=WENN(ODER($B7<E$1;$A7>E$2); "";MIN(E$2;$B7)-MAX(E$1;$A7)+1)
F7=WENN(ODER($B7<F$1;$A7>F$2); "";MIN(F$2;$B7)-MAX(F$1;$A7)+1)
G7=WENN(ODER($B7<G$1;$A7>G$2); "";MIN(G$2;$B7)-MAX(G$1;$A7)+1)
H7=WENN(ODER($B7<H$1;$A7>H$2); "";MIN(H$2;$B7)-MAX(H$1;$A7)+1)
I7=WENN(ODER($B7<I$1;$A7>I$2); "";MIN(I$2;$B7)-MAX(I$1;$A7)+1)
J7=WENN(ODER($B7<J$1;$A7>J$2); "";MIN(J$2;$B7)-MAX(J$1;$A7)+1)
K7=WENN(ODER($B7<K$1;$A7>K$2); "";MIN(K$2;$B7)-MAX(K$1;$A7)+1)
L7=WENN(ODER($B7<L$1;$A7>L$2); "";MIN(L$2;$B7)-MAX(L$1;$A7)+1)
M7=WENN(ODER($B7<M$1;$A7>M$2); "";MIN(M$2;$B7)-MAX(M$1;$A7)+1)
N7=WENN(ODER($B7<N$1;$A7>N$2); "";MIN(N$2;$B7)-MAX(N$1;$A7)+1)
O7=WENN(ODER($B7<O$1;$A7>O$2); "";MIN(O$2;$B7)-MAX(O$1;$A7)+1)
P7=WENN(ODER($B7<P$1;$A7>P$2); "";MIN(P$2;$B7)-MAX(P$1;$A7)+1)
C8=WENN(ODER($B8<C$1;$A8>C$2); "";MIN(C$2;$B8)-MAX(C$1;$A8)+1)
D8=WENN(ODER($B8<D$1;$A8>D$2); "";MIN(D$2;$B8)-MAX(D$1;$A8)+1)
E8=WENN(ODER($B8<E$1;$A8>E$2); "";MIN(E$2;$B8)-MAX(E$1;$A8)+1)
F8=WENN(ODER($B8<F$1;$A8>F$2); "";MIN(F$2;$B8)-MAX(F$1;$A8)+1)
G8=WENN(ODER($B8<G$1;$A8>G$2); "";MIN(G$2;$B8)-MAX(G$1;$A8)+1)
H8=WENN(ODER($B8<H$1;$A8>H$2); "";MIN(H$2;$B8)-MAX(H$1;$A8)+1)
I8=WENN(ODER($B8<I$1;$A8>I$2); "";MIN(I$2;$B8)-MAX(I$1;$A8)+1)
J8=WENN(ODER($B8<J$1;$A8>J$2); "";MIN(J$2;$B8)-MAX(J$1;$A8)+1)
K8=WENN(ODER($B8<K$1;$A8>K$2); "";MIN(K$2;$B8)-MAX(K$1;$A8)+1)
L8=WENN(ODER($B8<L$1;$A8>L$2); "";MIN(L$2;$B8)-MAX(L$1;$A8)+1)
M8=WENN(ODER($B8<M$1;$A8>M$2); "";MIN(M$2;$B8)-MAX(M$1;$A8)+1)
N8=WENN(ODER($B8<N$1;$A8>N$2); "";MIN(N$2;$B8)-MAX(N$1;$A8)+1)
O8=WENN(ODER($B8<O$1;$A8>O$2); "";MIN(O$2;$B8)-MAX(O$1;$A8)+1)
P8=WENN(ODER($B8<P$1;$A8>P$2); "";MIN(P$2;$B8)-MAX(P$1;$A8)+1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Gerd
Anzeige
AW: Monatstage eines Zeitraums auflisten
13.04.2009 20:11:03
Gerhard
Hallo Gerd,
danke für die Hilfe mit den gut verständlichen Formeln.
Gruß
Gerhard

309 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige