Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Wochentage Zählen mit Bedingung

Wochentage Zählen mit Bedingung
Michael
Hallo,
ich habe ein Problem, das ich nicht alleine lösen kann.
Ich habe ein Excel Liste, in der ich zählen möchte, an welchen Wochentagen Person x gearbeitet hat.
Hierfür habe ich zuerst einmal zwei spalten, in denen das Datum steht und die Person, die an dem Tag ihren Dienst geleistet hat (Liste ist nach Namen sortiert - Personen haben unterschiedlich oft Dienst geleistet).
Zusätzlich habe ich eine Spalten, in denen die Mitarbeiter alphabetisch aufgelistet sind. Daneben in den Spalten sind die Wochentage Mo-So aufgeführt (zum zählen).
Ich schaffe es zwar nun eine Formel zu finden, die alle Wochentage insgesamt korrekt zählt, und die die Tage nur zählt, wenn Person a in Liste 1 aufgeführt ist, jedoch werden dann hier auch alle Wochentage insgesamt und nicht nur die Pro Mitarbeiter gezählt.
Ich möchte also erreichen, dass auch nur in den Spalten die Wochentage gezählt werden, in der der jeweilige Mitarbeiter auch steht.
Ich hoffe ich habe mich verständlich ausgedrückt und ihr könnt mir helfen!
Vielen Dank!

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Wochentage Zählen mit Bedingung
10.08.2009 10:39:37
Ramses
Hallo
verständlich nicht zwingend, aber vielleicht doch so
Tabelle1

 ABCDEFGHIJKL
1DatumDienst  NameMoDiMiDoFrSaSo
201.01.2009MusterA  MusterA2211222
302.01.2009MusterA  MusterB0011110
403.01.2009MusterA  MusterC1112111
504.01.2009MusterA          
605.01.2009MusterA          
706.01.2009MusterA          
807.01.2009MusterA          
908.01.2009MusterC          
1009.01.2009MusterA          
1110.01.2009MusterA          
1211.01.2009MusterA          
1312.01.2009MusterA          
1413.01.2009MusterA          
1514.01.2009MusterC          
1615.01.2009MusterC          
1716.01.2009MusterC          
1817.01.2009MusterC          
1918.01.2009MusterC          
2019.01.2009MusterC          
2120.01.2009MusterC          
2221.01.2009MusterB          
2322.01.2009MusterB          
2423.01.2009MusterB          
2524.01.2009MusterB          
26            
27            

Formeln der Tabelle
ZelleFormel
F2=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=1)*($B$2:$B$25=$E2))
G2=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=2)*($B$2:$B$25=$E2))
H2=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=3)*($B$2:$B$25=$E2))
I2=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=4)*($B$2:$B$25=$E2))
J2=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=5)*($B$2:$B$25=$E2))
K2=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=6)*($B$2:$B$25=$E2))
L2=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=7)*($B$2:$B$25=$E2))
F3=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=1)*($B$2:$B$25=$E3))
G3=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=2)*($B$2:$B$25=$E3))
H3=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=3)*($B$2:$B$25=$E3))
I3=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=4)*($B$2:$B$25=$E3))
J3=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=5)*($B$2:$B$25=$E3))
K3=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=6)*($B$2:$B$25=$E3))
L3=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=7)*($B$2:$B$25=$E3))
F4=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=1)*($B$2:$B$25=$E4))
G4=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=2)*($B$2:$B$25=$E4))
H4=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=3)*($B$2:$B$25=$E4))
I4=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=4)*($B$2:$B$25=$E4))
J4=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=5)*($B$2:$B$25=$E4))
K4=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=6)*($B$2:$B$25=$E4))
L4=SUMMENPRODUKT((WOCHENTAG($A$2:$A$25;2)=7)*($B$2:$B$25=$E4))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruss Rainer
Anzeige
AW: Wochentage Zählen mit Bedingung
10.08.2009 10:45:35
Michael
Genau so war es gemeint!
Vielen Dank!!!

316 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige