Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

jede 10te Zeile auswählen (Bereich.Verschieben)

jede 10te Zeile auswählen (Bereich.Verschieben)
Dirk
Hallo :-),
ich habe folgendes Problem.
Ich habe eine Wertetabelle mit 43000 Zeilen und
möchte nur jede den Wert jeder 10ten Zeile mit der Funktion Bereich.Verschieben anzeigen lassen.
Allerdings kommt immer Bezugs- oder Wertfehler.
= Bereich.Verschieben(Zeile()-9)*10;0)
Kann mir jemand weiterhelfen?
Gruß
D

8
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
Index()
12.11.2009 15:37:30
Matthias5
Hallo,
ich würde dazu die Funktion Index() verwenden:
Tabelle1
 AB
1AA
2BK
3CU
4D 
5E 
6F 
7G 
8H 
9I 
10J 
11K 
12L 
13M 
14N 
15O 
16P 
17Q 
18R 
19S 
20T 
21U 
22V 
23W 
24X 
25Y 
26Z 

verwendete Formeln
Zelle Formel
B1 =INDEX(A:A;(ZEILE(A1)-1)*10+1)

Tabellendarstellung in Foren Version 4.8

Gruß,
Matthias
Anzeige
=BEREICH.VERSCHIEBEN(A10;(ZEILE()-9)*10;0) '_oT
12.11.2009 15:40:26
NoNet
_oT = "ohne TExt"
AW: =BEREICH.VERSCHIEBEN(A10;(ZEILE()-9)*10;0) '_oT
12.11.2009 17:33:53
jockel
hi NoNet, bist du sicher dass deine formel funzt...?
Tabelle1
 CDE
1AK#BEZUG!

verwendete Formeln
Zelle Formel
C1 =BEREICH.VERSCHIEBEN($A$1;(ZEILE()*10)-10;0)
D1 =BEREICH.VERSCHIEBEN($A$10;ZEILE()*10-9;0)
E1 =BEREICH.VERSCHIEBEN(A10;(ZEILE()-9)*10;0)

Tabellendarstellung in Foren Version 4.28


cu jörg
Anzeige
..ab Zeile 10 funzt es so...
12.11.2009 17:57:21
robert
=BEREICH.VERSCHIEBEN(A10;(ZEILE()-10)*9;0)
gruß
robert
(ZEILE()-9)*10 war ja bereits vorgegeben...
12.11.2009 17:57:55
NoNet
Hallo Jörg,
da der Part (ZEILE()-9)*10 ja bereits vorgegeben war, ging ich davon aus, dass das auch so beabsichtigt war.
Natürlich kann man diese Funktion dann erst ab Zeile 10 verwenden. Da ich Dirks Tabelle nicht kenne, gehe ich davon aus, dass diese Funktion tatsächlich erst ab Zeile 10 eingesetzt wird (weshalb sonst das -9 ?).
Gruß, NoNet
AW: jede 10te Zeile auswählen (Bereich.Verschieben)
12.11.2009 17:46:28
jockel
hi Dirk ich würde, wenn du das mit BEREICH.VERSCHIEBEN() machen möchtest, so tun...:
Tabelle1
 AB
1AA
2BK
3CU
4DAE
5EAO
6FAY
7G 
8H 
9I 
10J 
11K 
12L 
13M 
14N 
15O 
16P 
17Q 
18R 
19S 
20T 
21U 
22V 
23W 
24X 
25Y 
26Z 
27AA 
28AB 
29AC 
30AD 
31AE 
32AF 
33AG 
34AH 
35AI 
36AJ 
37AK 
38AL 
39AM 
40AN 
41AO 
42AP 
43AQ 
44AR 
45AS 
46AT 
47AU 
48AV 
49AW 
50AX 
51AY 
52AZ 
53BA 

verwendete Formeln
Zelle Formel
B1 =WENN(ZEILE()<=OBERGRENZE(ANZAHL2($A$1:$A$100)/10;1);BEREICH.VERSCHIEBEN($A$1;(ZEILE()*10)-10;0);"")
B2 =WENN(ZEILE()<=OBERGRENZE(ANZAHL2($A$1:$A$100)/10;1);BEREICH.VERSCHIEBEN($A$1;(ZEILE()*10)-10;0);"")
B3 =WENN(ZEILE()<=OBERGRENZE(ANZAHL2($A$1:$A$100)/10;1);BEREICH.VERSCHIEBEN($A$1;(ZEILE()*10)-10;0);"")
B4 =WENN(ZEILE()<=OBERGRENZE(ANZAHL2($A$1:$A$100)/10;1);BEREICH.VERSCHIEBEN($A$1;(ZEILE()*10)-10;0);"")
B5 =WENN(ZEILE()<=OBERGRENZE(ANZAHL2($A$1:$A$100)/10;1);BEREICH.VERSCHIEBEN($A$1;(ZEILE()*10)-10;0);"")
B6 =WENN(ZEILE()<=OBERGRENZE(ANZAHL2($A$1:$A$100)/10;1);BEREICH.VERSCHIEBEN($A$1;(ZEILE()*10)-10;0);"")
B7 =WENN(ZEILE()<=OBERGRENZE(ANZAHL2($A$1:$A$100)/10;1);BEREICH.VERSCHIEBEN($A$1;(ZEILE()*10)-10;0);"")
B8 =WENN(ZEILE()<=OBERGRENZE(ANZAHL2($A$1:$A$100)/10;1);BEREICH.VERSCHIEBEN($A$1;(ZEILE()*10)-10;0);"")

Tabellendarstellung in Foren Version 4.28



cu jörg eine rückmeldung wäre ganz reizend
Anzeige
jede 10te Zeile (INDEX , Bereich.Verschieben)
12.11.2009 18:13:32
Erich
Hi Dirk,
noch zwei Varianten, die hoffentlich genau so noch nicht genannt wurden:
(INDEX-Formel ist Matthias' Formel sehr ähnlich)
 ABC
1111
221111
332121
443131

Formeln der Tabelle
ZelleFormel
B1=BEREICH.VERSCHIEBEN(A$1;(ZEILE()-1)*10;0)
C1=INDEX(A:A;(ZEILE()-1)*10+1)
B2=BEREICH.VERSCHIEBEN(A$1;(ZEILE()-1)*10;0)
C2=INDEX(A:A;(ZEILE()-1)*10+1)
B3=BEREICH.VERSCHIEBEN(A$1;(ZEILE()-1)*10;0)
C3=INDEX(A:A;(ZEILE()-1)*10+1)
B4=BEREICH.VERSCHIEBEN(A$1;(ZEILE()-1)*10;0)
C4=INDEX(A:A;(ZEILE()-1)*10+1)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige
oder...
12.11.2009 22:15:28
jockel
... noch anders...:
Tabelle1
 AB
7G 
8H 
9I 
10JJ
11KT
12LAD
13MAN
14NAX
15O 
16P 
17Q 
18R 
19S 
20T 
21U 
22V 
23W 
24X 
25Y 
26Z 
27AA 
28AB 
29AC 
30AD 
31AE 
32AF 
33AG 
34AH 
35AI 
36AJ 
37AK 
38AL 
39AM 
40AN 
41AO 
42AP 
43AQ 

verwendete Formeln
Zelle Formel
B10 =INDIREKT("A"&(ZEILE()-9)*10)

Tabellendarstellung in Foren Version 4.28


cu jörg
Anzeige

10 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige