Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Image
BildScreenshot zu Image Image-Seite mit Beispielarbeitsmappe aufrufen

Rang sortieren nach 3 Bedingungen | Herbers Excel-Forum


Betrifft: Rang sortieren nach 3 Bedingungen von: Günther Franzke
Geschrieben am: 14.11.2009 13:25:23

Moin Moin
habe mal wieder ein problemchen.
Seit einer Woche versuche ich es hinzubiegen.
Habe eine tabelle die so sortiert wird mit 3 Bedingungen.
in Spalte a sollte die nach Rang sortiert werden.
send die Datei mit.

https://www.herber.de/bbs/user/65895.xls

denn ich weiss nicht mehr weiter, und hoffe das mir einer es lösen kann.
Danke im Vorraus
MFG
Günther
Office 2003

  

Betrifft: AW: Rang sortieren nach 3 Bedingungen von: Klaus-Dieter
Geschrieben am: 14.11.2009 13:35:50

Hallo Günther,

warum willst du das mit Formeln lösen? Das kannst du doch ganz einfach mit der Standardsortierung von Excel machen.

Tippauswertung

 APAQARAS
34961621
44481652
54481533
64321474
74321474
8432  8
94251466
104251127

Formeln der Tabelle
ZelleFormel
AP3=WENN(SUMME(AN3:AO3)=0;"";SUMME(AN3:AO3))
AP4=WENN(SUMME(AN4:AO4)=0;"";SUMME(AN4:AO4))
AP5=WENN(SUMME(AN5:AO5)=0;"";SUMME(AN5:AO5))
AP6=WENN(SUMME(AN6:AO6)=0;"";SUMME(AN6:AO6))
AP7=WENN(SUMME(AN7:AO7)=0;"";SUMME(AN7:AO7))
AP8=WENN(SUMME(AN8:AO8)=0;"";SUMME(AN8:AO8))
AP9=WENN(SUMME(AN9:AO9)=0;"";SUMME(AN9:AO9))
AP10=WENN(SUMME(AN10:AO10)=0;"";SUMME(AN10:AO10))




Viele Grüße Klaus-Dieter

Klaus-Dieter's Excel und VBA Seite
Online-Excel


  

Betrifft: AW: Rang sortieren nach 3 Bedingungen von: Günther Franzke
Geschrieben am: 14.11.2009 14:05:30

Moin Moin Dieter
so weit so gut
es sollte in Spalte a die plätze stehen,
denn wenn in Spalte AP gleich ist,
dann vergleichen mit Spalte AQ,
wenn dann noch gleich ist dann mit Spalte AR,
dann müßte in Spalte A (Beispiel Spalte AS) es so stehen.
https://www.herber.de/bbs/user/65897.xls
Günther
2003


  

Betrifft: AW: Rang sortieren nach 3 Bedingungen von: Günther Franzke
Geschrieben am: 14.11.2009 14:23:47

Die Standardsortierung habe ich schon mit einem macro geschaft.
Die Tipptabelle in Spalte A sortiert mir nur, das ich einige Plätze
doppelt habe, weil ich die rangfolge
=RANG(AP3;$AP$3:$AP$10) formatiert habe,
oder ich muss die Formel weg lassen.
günther


  

Betrifft: AW: Rang sortieren nach 3 Bedingungen von: Günther Franzke
Geschrieben am: 14.11.2009 14:59:32

Die Standardsortierung habe ich schon mit einem macro geschaf
günther


  

Betrifft: AW: Rang sortieren nach 3 Bedingungen von: fcs
Geschrieben am: 15.11.2009 16:17:38

Hall Günther,

füge für die Rang-Berechnung eine Hilfsspalte ein, z.B AU
Formel in AU3:

=AP3*100000+AQ3*1000+AR3

Diese Formel dann nach unten kopieren. Mit dieser Formel ergibt sich für die Kombination der Werte aus AP, AQ und AR ein für die Rangberechnung eindeutiger Wert.

Bei der Rangberechnung in Spalte A benutzt du dann die Werte in der Hilfsspalte als Basis.

Gruß
Franz


  

Betrifft: Danke das wars von: Günther Franzke
Geschrieben am: 15.11.2009 17:26:45

super das klapt .
habe noch eine frage.
warum mal 100000 oder 1000??
danke
günther


  

Betrifft: AW: Danke das wars von: fcs
Geschrieben am: 15.11.2009 21:31:22

Hallo Günther,

die Multiplikatoren müssen so gewählt werden, dass sich sich der höher rangige Wert ohne Überschneidung immer komplett vor die anderen Zahlen schreibt.

Der Multiplikator wird also durch die Größte Zahl des jeweils zu betrachtenden Segments bestimmt.
In deinem Fall bin ich davon ausgegangen, dass
in AR Werte zwischen 0 und 999 stehen werden - deswegen Spalte AQ-Werte *1000
in AQ Werte von 1 bis 99 - deswegen Spalte AP-Werte *1000*100 = * 100000
in AP können dann beliebige Werte stehen, wobei das Ganze "nur" Zahlen mit max. 15 Ziffern korrekt verarbeitet.

Gruß
Franz


  

Betrifft: AW: Danke das wars von: Günther Franzke
Geschrieben am: 16.11.2009 11:44:53

Hallo Franz
Habe mal wieder was dazu gelehrnt.
Super Forum
Danke
Gruß
Günther


Beiträge aus den Excel-Beispielen zum Thema "Rang sortieren nach 3 Bedingungen"