Microsoft Excel

Herbers Excel/VBA-Archiv

Summenprodukt oder gibt es eine schnellere Lösung | Herbers Excel-Forum


Betrifft: Summenprodukt oder gibt es eine schnellere Lösung von: Detlef
Geschrieben am: 16.11.2009 18:38:00

Hallo alle zusammen,

ich habe ein Datengrab Bereich A1:BT43225, das ich mit folgender Formel auswerte

=SUMMENPRODUKT(('Import 1'!$A$3:$A$43225=TEXT($B3;"@"))*('Import 1'!$H$3:$H$43225>=DATUM(2009;1;1) )*(INDIREKT("'Import 1'!$"&BR$1&"$3:$"&BR$1&"$43225")))

Diese Formel befindet sich in einem Bereich BR3:DI804. Weitere Spalten kommen wohl noch hinzu. Das Neuberechnen dauert schon reichlich lang. Gibt es da schnellere Alternativen, evtl. per VBA.

Ich habe eine Leitspalte zu der ich mir die Werte nach unterschiedlichen Kriterien (in diesem Fall Zeitachse) hole.

Gruß Detlef

  

Betrifft: AW: Summenprodukt oder gibt es eine schnellere Lösung von: ransi
Geschrieben am: 16.11.2009 19:59:42

HAllo Detlef

HASt du mal eine abgespeckte Beispieldatei ?
Sich Anhand der Formel eine Tabelle zu basteln ist doch mehr als umständlich...

ransi


  

Betrifft: AW: Summenprodukt oder gibt es eine schnellere Lösung von: Detlef
Geschrieben am: 16.11.2009 20:50:00

Hallo ransi,

hier die abgespeckte Musterdatei.

https://www.herber.de/bbs/user/65959.xls

Gruß Detlef


Beiträge aus den Excel-Beispielen zum Thema "Summenprodukt oder gibt es eine schnellere Lösung"