Microsoft Excel

Herbers Excel/VBA-Archiv

Bedingte Formatierung: Zahl einfügen | Herbers Excel-Forum


Betrifft: Bedingte Formatierung: Zahl einfügen von: Chris
Geschrieben am: 17.11.2009 11:52:17

Hi,

ich möchte mittels einer bedingten Formatierung eine Zelle färben und den Wert 0 reinschreiben lassen.
Und zwar wenn B5<=C7 zutrifft, soll sich zelle D8 lila färben und der Wert 0 soll in der Zelle stehen.

Das Färben der Zelle kriege ich mit folgender Bedingung hin:
Formel ist = B5<=C7

Aber eine Zahl bekomme ich da nicht rein, wenn ich eine Formatierung folgendermaßen versuche:
Formel ist = Wenn(B5<=C7; "0","")

Was läuft da wohl falsch?

  

Betrifft: AW: Bedingte Formatierung: Zahl einfügen von: Björn B.
Geschrieben am: 17.11.2009 11:56:32

Hallo,

hast Du die Formel bei "bedingter Formatierung" eingegeben?

Wenn das so ist, dann solltest Du nochmal genau überlegen, was Du da grad geschrieben hast.
Was bedeutet denn Formatierung?
Du möchtsest, dass abhängig von einem Wert eine 0 irgendwo erscheint, das ist eine ganz einfache Wenn-Formel, die aber in der Zelle stehen muss.
Daher wundert mich die Einstufung Excel-gut ;-)

Gruß
Björn


  

Betrifft: AW: Bedingte Formatierung: Zahl einfügen von: Chris
Geschrieben am: 17.11.2009 12:06:45

Das ist mir schon klar, dass ich eine Formel in die Zelle schreiben kann.
Nur ist es so, dass sich die Werte in B5 und C7 von Monat zu Monat ändern können und sich demnach auch die bedingte Formatierung in D8 ändern kann.

Und wenn B5 > C7, dann muss man einen Wert händisch in C8 eintragen....damit würde ich dann aber eine hinterlegte Wenn-Formel in C8 überschreiben.
DEshalb möchte ich das mit der bedingten Formatierung lösen.


  

Betrifft: AW: Bedingte Formatierung: Zahl einfügen von: Mike
Geschrieben am: 17.11.2009 12:26:41


Hey Chris,

Du musst Dein Anliegen zweiteilen:

- in der Zelle steht die Wenn-Formel, die auch eine 0 schreiben kann, je nach Bedingung
- in der bedingten Formatierung wird das Format zugeteilt, eher kein schreiben möglich

Gruss
Mike


  

Betrifft: und noch .. Bedingte Formatierung: Zahl einfügen von: Mike
Geschrieben am: 17.11.2009 12:30:27

.. und noch als "doppeltes" Beispiel:


Tabelle3

 BCD
52   
6     
7  1 
8    sonstwas
9     
101   
11     
12  1 
13    0
Bedingte Formatierung wird in dieser Tabelle nicht dargestellt

verwendete Formeln
Zelle Formel
D8 =WENN(B5<=C7; 0; "sonstwas")
D13 =WENN(B10<=C12; 0; "sonstwas")

bedingte Formatierung
Zelle   Typ   Operator   Formel1   Formel2   Format   Unterstrichen   Schrift- farbe Muster   Muster- farbe
D81.Bed.: Formel ist   =B5<=C7   13408767        
D131.Bed.: Formel ist   =B10<=C12   13408767        

Tabellendarstellung in Foren Version 4.28



Gruss
Mike


  

Betrifft: AW: Bedingte Formatierung: Zahl einfügen von: Björn B.
Geschrieben am: 17.11.2009 12:35:04

Nochmal, Du verstehst nicht, was ne Formatierung ist...
Format hat absolut überhaupt nichts mit Wert zu tun.

Du willst keine bedingte Formatierung, Du willst einen bedingten Wert, und das geht eben nun mal nicht über eine Formatierung. Verstanden?

Deshalb kannst Du das nicht mit ner bedingten Formatierung machen.

Nimm ne Hilfsspalte oder Du musst es mit VBA lösen.

Gruß
Björn B.


  

Betrifft: AW: Bedingte Formatierung: Zahl einfügen von: Chris
Geschrieben am: 17.11.2009 13:19:44

Ok, dann sind meine Excel-Kenntnisse "gut" relativ zu verstehen ;-)

Wie könnte ich das denn mit VBA lösen?

Wenn sich Zelle D8 lila färbt, dann trage Wert 0 in Zelle ein.


  

Betrifft: wieso .. Zahl / Format von: Mike
Geschrieben am: 17.11.2009 13:28:44


Hey Chris,

wieso VBA, war mein Beispiel nicht klar? Die Wenn-Abfrage bezüglich der 0 kannst Du dann natürlich auch in bestehende Formeln integrieren.

Gruss
Mike


  

Betrifft: AW: wieso .. Zahl / Format von: Chris
Geschrieben am: 17.11.2009 13:54:29

Doch schon, glaube ich zumindest.
Aber in deinem Beispiel steht in D8 ja eine Formel, die eine "0" einträgt, wenn B5 <= C7.
Und wenn nicht, dann schreibts "sonstwas".

Aber ich will da nichts festes reinschreiben lassen, wenn der Sonst-Fall eintritt. Wenn der Sonst-Fall eintritt, soll die Zelle leer bleiben, da sie dann händisch gepflegt werden muss. Und das was da händisch eingetragen wird, wird dann die Wenn-Formel überschreiben.


  

Betrifft: viel Spass .. Zahl / Format von: Mike
Geschrieben am: 17.11.2009 14:11:01


... da dann viel Spass mit VBA .. ;-) ... Hilfsspalte als Stichwort is ja auch schon
gefallen, somit liesse sich das VBA umgehen, wenn es die Struktur überhaupt
zulässt.

Gruss
Mike


  

Betrifft: AW: wieso .. Zahl / Format von: Björn B.
Geschrieben am: 17.11.2009 14:11:21

Also ich würde auch ne zusätzliche Spalte nehmen.
Eingabespalte und Anzeigespalte.
In Eingabespalte kannst du immer eingeben.

In Anzeigespalte machst du deine bedingte Formatierung und machst die "bedingte Anzeige".
Also wenn B5 <= C7 dann steht ne 0 da, und wenn nicht, dann wird der Wert aus der Eingabespalte genommen.
Du kannst sogar noch abfangen, dass B5 <= C7 und was in der Eingabespalte nicht zusammen vorkommen darf.

Gruß
Björn B.


  

Betrifft: AW: wieso .. Zahl / Format von: Chris
Geschrieben am: 17.11.2009 14:13:59

Ok, dann verusche ich das mal so.

Danke an alle für die Tipps.


  

Betrifft: AW: Bedingte Formatierung: Zahl einfügen von: Heinz H
Geschrieben am: 17.11.2009 11:56:47

Hallo Chris

Wenn(B5<=C7; "0";"")

So funkt.es
Gruß
Heinz


  

Betrifft: AW: Bedingte Formatierung: Zahl einfügen von: Chris
Geschrieben am: 17.11.2009 12:08:24

Auch mit korrigiertem ; klappt es nicht?!?


  

Betrifft: AW: mit VBA von: hary
Geschrieben am: 17.11.2009 16:14:34

Hi Chris
Mal mit VBA. Kommentar in Tab.
https://www.herber.de/bbs/user/65984.xls
gruss hary
fuer die mitleser, hab's so gemacht.:

Private Sub Worksheet_Change(ByVal Target As Excel.Range)
If Range("B5") <= Range("C7") Then
 Range("D8").Interior.ColorIndex = 7
 Range("D8") = 0
Else
Range("D8").Interior.ColorIndex = xlNone
End If
End Sub



Beiträge aus den Excel-Beispielen zum Thema "Bedingte Formatierung: Zahl einfügen"