Microsoft Excel

Herbers Excel/VBA-Archiv

Stunden nach Vorgabe teilen in Tage/Std/Min | Herbers Excel-Forum


Betrifft: Stunden nach Vorgabe teilen in Tage/Std/Min von: Klaus
Geschrieben am: 19.11.2009 17:54:59

Hallo Forum,
ich knacke gerade an einer Zeitformel:

In A1 steht z.B. 24:30 (Format [h]:mm)
In B1 steht eine (variable) Stundenzahl, z.B. 8
In C1 soll jetzt die Auswertung stehen: 3 Tage, 0:30 Std (immer auf Basis der variablen Stundenzahl)
Bei B1 = 4 dann also: 6 Tage, 0:30 Std

Kann mir einer der Cracks da unter die Arme greifen?

Danke
Klaus

  

Betrifft: ein Versuch... von: Tino
Geschrieben am: 19.11.2009 18:22:41

Hallo,
ich hoffe es passt so

Tabelle2

 ABC
124:3046 Tage 00:30 Stunden
224:3083 Tage 00:30 Stunden

Formeln der Tabelle
ZelleFormel
C1=GANZZAHL(A1)*24/B1& " Tage " & TEXT(REST(A1;1); "hh:mm")&" Stunden"
C2=GANZZAHL(A2)*24/B2& " Tage " & TEXT(REST(A2;1); "hh:mm")&" Stunden"


Gruß Tino


  

Betrifft: Klappt noch nicht von: Klaus
Geschrieben am: 19.11.2009 18:32:45

Hallo Tino,
danke für Deine Hilfe, aber bei z.B. 7,7 als Teiler
wird es 3,11688311688312 Tage 00:30 Std.

Hmmm ...
Klaus


  

Betrifft: besser bekomme ich es nicht hin... von: Tino
Geschrieben am: 19.11.2009 18:41:12

Hallo,

 ABC
124:307,72 Tage 3:18 Stunden
224:3072 Tage 10:47 Stunden

Formeln der Tabelle
ZelleFormel
C1=GANZZAHL(GANZZAHL((GANZZAHL(A1)*24/B1))-REST(GANZZAHL(A1)*24/B1;1))& " Tage " & TEXT(REST(GANZZAHL(A1)*24/B1;1)+REST(A1;1); "[h]:mm")&" Stunden"
C2=GANZZAHL(GANZZAHL((GANZZAHL(A2)*24/B2))-REST(GANZZAHL(A2)*24/B2;1))& " Tage " & TEXT(REST(GANZZAHL(A2)*24/B2;1)+REST(A2;1); "[h]:mm")&" Stunden"


Eigentlich müsste man die 10:47 auch wieder separat berechnen,
so gut bin ich aber in Sachen Formeln nicht.

Gruß Tino


  

Betrifft: geht leider immer noch nicht von: Klaus
Geschrieben am: 19.11.2009 18:52:50

Hallo Tino,
bei zum Beispiel 9 wirft er 1 Tag 16:30 Std aus ...

Trotzdem vielen Dank für Deine Mühe,
vielleicht hat ja jemand anderes noch eine zündende Idee.

Lieben Gruß aus Hamburg
Klaus


  

Betrifft: da hat er sich vergalloppiert von: WF
Geschrieben am: 19.11.2009 18:59:14

Hi Klaus,

=GANZZAHL(A1*24/B1)&" Tage "&TEXT(A1-GANZZAHL(A1/(B1/24))*B1/24;"hh:mm")&" Stunden"

Salut WF



http://www.excelformeln.de/
die ultimative Formelseite


  

Betrifft: Entweder man kann es oder nicht... von: Tino
Geschrieben am: 19.11.2009 19:05:11

Hallo,
Du kannst ;-)

Gruß Tino


  

Betrifft: Dein grundsätzlicher Fehler ist nur eine Klammer von: WF
Geschrieben am: 19.11.2009 19:16:32

Hi Tino,

schon bei Deinem ersten Versuch
=GANZZAHL(A1)*24/B1
gehört nur die schließende Klammer nach hinten:
=GANZZAHL(A1*24/B1)

Salut WF


  

Betrifft: Klappt super! von: Klaus
Geschrieben am: 19.11.2009 19:20:01

Hallo WF,
ganz herzlichen Dank! Klappt super.

Und auch noch mal vielen Dank an Tino für die Vorarbeit.

Gruß
Klaus


  

Betrifft: hier noch mein Senf dazu von: Josef Ehrensberger
Geschrieben am: 19.11.2009 19:23:31

Hallo Klaus,

Tabelle1

 ABC
124:3083 Tage, 00:30 Std
28:4581 Tag, 00:45 Std
336:50103 Tage, 06:50 Std
483:25810 Tage, 03:25 Std

Formeln der Tabelle
ZelleFormel
C1=GANZZAHL((A1*24)/B1)&" Tag"&WENN(GANZZAHL((A1*24)/B1)<>1;"e, ";", ")&TEXT(((A1*24)-GANZZAHL((A1*24)/B1)*B1)/24;"hh:mm \S\t\d")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: wenn schon Optik, sieht ... von: WF
Geschrieben am: 19.11.2009 19:34:03

Hi Sepp,

...
0 Tage, 06:15 Std
aber auch bescheuert aus - also dann konsequenterweise nur
06:15 Std

Salut WF


  

Betrifft: mehr Senf von: Erich G.
Geschrieben am: 19.11.2009 19:49:56

Hi zusammen,
mein Vorschlag:

 ABC
124:30:007,003 Tage 03:30 Stunden
225:00:0055 Tage
32:30:00502:30 Stunden

Formeln der Tabelle
ZelleFormel
C1=WENN(A1*24<B1;"";KÜRZEN(A1*24/B1;)&" Tage ") & WENN(ABS(REST(A1;B1/24))<10^(-14); "";TEXT(REST(A1;B1/24); "hh:mm")&" Stunden")

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: 1 Tage - setzen sechs !? von: WF
Geschrieben am: 19.11.2009 19:54:17

.


  

Betrifft: kommt ja schon... von: Erich G.
Geschrieben am: 19.11.2009 20:00:27

Hi,

 ABC
124:30:007,003 Tage 03:30 Stunden
225:00:0055 Tage
32:30:00502:30 Stunden
40:00:007,00 
55:30:005,001 Tag 00:30 Stunden

Formeln der Tabelle
ZelleFormel
C1=WENN(A1*24<B1;"";KÜRZEN(A1*24/B1;)&" Tag"&WENN(GANZZAHL(A1*24/B1)=1;" ";"e ")) & WENN(ABS(REST(A1;B1/24))<10^(-14); "";TEXT(REST(A1;B1/24); "hh:mm")&" Stunden")

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: langt nicht - 17:00 bei 8 ergibt 2 Tage, 1 Stunden von: WF
Geschrieben am: 19.11.2009 20:07:34

.


  

Betrifft: dann Std. stattr Stunden? :-)) (owT) von: Erich G.
Geschrieben am: 19.11.2009 20:10:15




  

Betrifft: zu banal - dann geht ja auch T. von: WF
Geschrieben am: 19.11.2009 20:14:02

.


  

Betrifft: na gut, dann Stunde & n mit WENN von: Erich G.
Geschrieben am: 19.11.2009 20:19:35

Hi,
dann so?

 ABC
124:30:007,003 Tage 03:30 Stunden
225:00:0055 Tage
32:30:00502:30 Stunden
40:00:007,00 
55:30:005,001 Tag 00:30 Stunden
617:00:008,002 Tage 01:00 Stunde

Formeln der Tabelle
ZelleFormel
C1=WENN(A1*24<B1;"";KÜRZEN(A1*24/B1;)&" Tag"&WENN(KÜRZEN(A1*24/B1;)=1;" ";"e ")) & WENN(ABS(REST(A1;B1/24))<10^(-14); "";TEXT(REST(A1;B1/24); "hh:mm")&" Stunde"&WENN(REST(A1*24;B1)=1;"";"n"))

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: OT @ WF: zu excelformeln.de von: Erich G.
Geschrieben am: 19.11.2009 20:14:12

Hi Walter,
vor ein paar Tagen (10.11. und 14.11.) hab ich euch über die Kontaktseite zwei Meldungen
zu den Formeln 141 (DATEDIF) und 7 (DIN-KW) geschickt.

Hast du davon etwas gesehen?

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: hab ich nicht - Boris ist z.Zt. Antworter von: WF
Geschrieben am: 19.11.2009 20:19:37

.


  

Betrifft: Hab ich gelesen... von: {Boris}
Geschrieben am: 23.11.2009 17:55:08

Hi Erich,

...aber da muss ich mich erst reindenken. Antwort folgt :-)

Grüße Boris


  

Betrifft: dann genügt aber von: FP
Geschrieben am: 20.11.2009 20:15:59

Hallo Erich,

=TEXT(KÜRZEN(A1*24/B1);"[>=2]0"" Tage "";[>0]0"" Tag "";")&TEXT(REST(A1*24;B1)/24; "hh:mm ""Stunden""")

und damit es auch wirklich schön ausgeschrieben steht wie man es sagt:

z.B. 3 Tage 6 Stunden 45 Minuten oder 1 Tag 1 Stunde 1 Minute usw.

=TEXT(KÜRZEN(A1*24/B1);"[>=2]0 ""Tage "";[>0]0 ""Tag "";")&TEXT(KÜRZEN(REST(A1*24;B1));"[> =2]0 ""Stunden "";[>0]0 ""Stunde "";")&TEXT(REST(REST(A1*24;B1);1)*60;"[>1+59/60]0 ""Minuten""; [>0]0 ""Minute"";")

Schönes Wochenende und

Servus aus dem Salzkammergut
Franz


  

Betrifft: @Franz: Simply GREAT! Auch schönes WoEnde! von: Erich G.
Geschrieben am: 20.11.2009 20:53:33

(weitere Worte (und Formeln) erübrigen sich...)


  

Betrifft: noch n klein bischen kürzer von: Erich G.
Geschrieben am: 19.11.2009 20:07:45

Hi zusammen,

 ABCD
124:30:007,003 Tage 03:30 Stunden3 Tage, 03:30 Std
225:00:0055 Tage 5 Tage, 00:00 Std
32:30:00502:30 Stunden02:30 Std
40:00:007,00 00:00 Std
55:30:005,001 Tag 00:30 Stunden1 Tag, 00:30 Std

Formeln der Tabelle
ZelleFormel
C1=WENN(A1*24<B1;"";KÜRZEN(A1*24/B1;)&" Tag"&WENN(KÜRZEN(A1*24/B1;)=1;" ";"e ")) & WENN(ABS(REST(A1;B1/24))<10^(-14); "";TEXT(REST(A1;B1/24); "hh:mm")&" Stunden")
D1=WENN(GANZZAHL((A1*24)/B1)=0;"";GANZZAHL((A1*24)/B1)&WENN(GANZZAHL((A1*24)/B1)=1;" Tag, ";" Tage, ")) & TEXT(((A1*24)-GANZZAHL((A1*24)/B1)*B1)/24;"hh:mm \S\t\d")

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: wenn schon Optik, sieht ... von: Josef Ehrensberger
Geschrieben am: 19.11.2009 19:57:45

Hallo Meister,

na dann so.

Tabelle1

 ABC
124:3083 Tage, 00:30 Std
28:4581 Tag, 00:45 Std
39:551009:55 Std
483:25810 Tage, 03:25 Std

Formeln der Tabelle
ZelleFormel
C1=WENN(GANZZAHL((A1*24)/B1)=0;"";GANZZAHL((A1*24)/B1)&WENN(GANZZAHL((A1*24)/B1)=1;" Tag, ";" Tage, "))&TEXT(((A1*24)-GANZZAHL((A1*24)/B1)*B1)/24;"hh:mm \S\t\d")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: kein schlechter Senf! von: Klaus
Geschrieben am: 19.11.2009 19:45:46

Hallo Sepp,
auch Dir ein kräftiges Dankeschön – Du hast ja sogar
Tag/Tage mit eingebaut ... toll.

Ihr seid alle echt klasse hier ...

So long
Klaus


Beiträge aus den Excel-Beispielen zum Thema "Stunden nach Vorgabe teilen in Tage/Std/Min"