Microsoft Excel

Herbers Excel/VBA-Archiv

Summe pro (Kalender)Woche | Herbers Excel-Forum


Betrifft: Summe pro (Kalender)Woche von: Thomas Speiser
Geschrieben am: 27.11.2009 17:11:36

Hallo an alle zusammen,

ich habe schon im Archiv gesucht, bin aber nicht für meine Zwecke fündig geworden.

Ich muss eine Statistik entwickeln aus der Zahlen von versch. Blätter und Mappen einfließen. Mein Problem ist das ich die summierten Zaheln pro (Kalender)Woche ausgeben muss.

Im beigefügten Beispiel habe ich Ausschnittweise einige Summenfragen grün gekennziechnet.

https://www.herber.de/bbs/user/66231.xls

Die Summe einer (Kalender)Woche ergibt sich immer aus der Summe der Tagessummen einer ganzen Woche.
Falls es nicht mit einer Formel geht, könnt Ihr mir auch gerneein VBA Skript senden.

Hoffe ist verständlich.
Danke und Gruß
Thomas

  

Betrifft: AW: Summe pro (Kalender)Woche von: serge
Geschrieben am: 27.11.2009 17:22:52

Hallo Thomas
so : https://www.herber.de/bbs/user/66232.xls
F4 und mehr musst Benutzer Formatieren!
Serge


  

Betrifft: Korrektur von: serge
Geschrieben am: 27.11.2009 17:25:06

G4 soll so sein :=SUMMEWENN($B$5:$B$52;F4;$D$5:$D$52) und runterkopieren
Serge


  

Betrifft: Danke aber kleine RÜ von: Thomas Speiser
Geschrieben am: 27.11.2009 17:27:58

Hallo Serge,

suuper, aber wie hast Du das mit F4 bis F10 gemacht. Kenne ich noch gar nicht.
Gruß
Thomas


  

Betrifft: gefunden und kapiert von: Thomas Speiser
Geschrieben am: 27.11.2009 17:31:31

Hallo Serge,

schon gefunden und kapiert, über benutzerdefiert.....

Danke, funzt super.


  

Betrifft: AW: Summe pro (Kalender)Woche von: Detlef
Geschrieben am: 27.11.2009 17:25:49

Hallo Thomas,

mit summewenn in G4 bzw. G5, dann weiter runterkopieren.



 ABCDEFG
1     aktueller Tag27.11.2009
2     aktuelle Kalenderwoche48
3  2009    
4 KalenderwocheTagTAGESSUMME Summe aus Kalenderwoche 16,00 €
5 1Do, 01.01.091,00 € Summe aus Kalenderwoche 249,00 €
6 1Fr, 02.01.092,00 € Summe aus Kalenderwoche 3 
7 1Sa, 03.01.093,00 € Summe aus Kalenderwoche 4 
8 2So, 04.01.094,00 € Summe aus Kalenderwoche 5 
9 2Mo, 05.01.095,00 € Summe aus Kalenderwoche 6 
10 2Di, 06.01.096,00 € Summe aus Kalenderwoche 7 

Formeln der Tabelle
ZelleFormel
G1=HEUTE()
G2=KALENDERWOCHE(G1;1)
G4=SUMMEWENN(B:B;RECHTS(F4;2); D:D)
B5=KALENDERWOCHE(C5;1)
C5=DATUM(C3;1;1)
G5=SUMMEWENN(B:B;RECHTS(F5;2); D:D)
B6=KALENDERWOCHE(C6;1)
C6=C5+1
B7=KALENDERWOCHE(C7;1)
C7=C6+1
B8=KALENDERWOCHE(C8;1)
C8=C7+1
B9=KALENDERWOCHE(C9;1)
C9=C8+1
B10=KALENDERWOCHE(C10;1)
C10=C9+1


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Detlef


  

Betrifft: geht es so, Dein Beispiel. von: Tino
Geschrieben am: 27.11.2009 17:36:42

Hallo,

https://www.herber.de/bbs/user/66234.xls

Gruß Tino


  

Betrifft: an Detlef und Tino von: Thomas Speiser
Geschrieben am: 27.11.2009 17:45:26

Hallo Euch beiden,

vielen Dank, werde jetzt mal das für mich beste aus allem zusammenstellen.

DAnke
Gruß
Thomas


Beiträge aus den Excel-Beispielen zum Thema "Summe pro (Kalender)Woche"