Microsoft Excel

Herbers Excel/VBA-Archiv

4 Kriterien, davon 2 VErgleichen | Herbers Excel-Forum


Betrifft: 4 Kriterien, davon 2 VErgleichen von: zellner
Geschrieben am: 29.11.2009 20:37:10

Hallo zusammen,
ich hab mal wieder eine Frage:
In einer Tabelle gebe ich Werte aus, die aus einer nebenstehenden Tabelle stammen, insgesamt 4 Werte, davon können über Formel alle, eine, zwei oder drei =0 sein (einfache wennformel und sverweis).
Jetzt möchte ich einen Fall vergleichen:
NUR WENN ZWEI GLEICHE WERTE STEHEN, dann soll eine 1 ausgegeben werden, wenn die Werte unterschiedlich sind, dann eine 0. (rot geschrieben in den fett umrandeten Zellen)
Ist bestimmt einfach, ich weiß aber nicht wie ich das hinbekomme, die minfunktion gibt mir ja immer dann 0 aus.
Hier das Beispiel: https://www.herber.de/bbs/user/66264.xls
Danke schon mal
Gruß
Raphael

  

Betrifft: AW: 4 Kriterien, davon 2 VErgleichen von: Josef Ehrensberger
Geschrieben am: 29.11.2009 20:47:37

Hallo Raphael,


http://www.excelformeln.de/formeln.html?welcher=185


Tabelle1

 F
71

Formeln der Tabelle
ZelleFormel
F7=WENN(ISTFEHLER(MODALWERT(A1:A100)); 1;0)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: Oups, falschen Tabellenausschnitt erwischt. von: Josef Ehrensberger
Geschrieben am: 29.11.2009 20:49:22

Hallo nochmal,

jetzt stimmts.

Tabelle1

 BCDEF
2DatenübernahmeGrenzwertABCD Zahlen% Zuordnung
3A0600
4B64270
5C116380
6D3300
7   21
8Kennzahl    
9     

Formeln der Tabelle
ZelleFormel
F7=WENN(ISTFEHLER(MODALWERT(F3:F6)); 0;1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4





Gruß Sepp



  

Betrifft: AW: Oups, falschen Tabellenausschnitt erwischt. von: zellner
Geschrieben am: 29.11.2009 21:08:44

Hallo Sepp,
hab meine Tabelle ein wenig umbauen müssen, aber mit der Formel gehts. Modalwert kannte ich noch nicht, ist genial. Statt eine 0 bei den % auszugeben habe ich nun "" drin, sonst würde er ja immer die 2 nullen als gleich erkennen.
Danke und schönen Abend noch
Gruß
Raphael


  

Betrifft: AW: 4 Kriterien, davon 2 VErgleichen von: Daniel
Geschrieben am: 29.11.2009 20:48:55

HI

probier mal diese Formel (ist ne Matrix-Formel, dh. Eingabe mit STRG+SHIFT+ENTER abschließen)

=(SUMME(1/ZÄHLENWENN(F3:F6;F3:F6))=(ZEILEN(F3:F6)-1))*1

die Formel liefert eine 1, wenn im angegeben Zellbereich genau 2 Zellen den gleichen Wert haben.
ansonsten gibts ne 0

Gruß, Daniel


Beiträge aus den Excel-Beispielen zum Thema "4 Kriterien, davon 2 VErgleichen"