Microsoft Excel

Herbers Excel/VBA-Archiv

INDIREKT mit eingebetter Kalkulation | Herbers Excel-Forum


Betrifft: INDIREKT mit eingebetter Kalkulation von: Berndt von Uslar Gleichen
Geschrieben am: 29.11.2009 23:52:43

Hola, saludos liebes Forum.
Aller guten Dinge sind drei. Zwei mal habt Ihr mir heute schon ganz toll helfen können!

In Zelle A1 habe ich eine Formel: =($C1+$D1)/2. Nun lasse ich über ein Makro 2 Spalten vor Spalte C einfügen.
Nun haut das nicht mehr hin, weil die Formel in Zelle A1 umgeschrieben wird. Oft schon angesprochen. Als Lösung wird dann die Funktion INDIREKT angeführt. Dies funktioniert auch aaaber anscheinend nicht, wenn, wie in meinem Fall, eine Formel steht. Wer weiß Abhilfe?
Noch einmal Dank im voraus; ganz besonders an Hajo
Gruß Bernardo

  

Betrifft: AW: INDIREKT mit eingebetter Kalkulation von: Beate Schmitz
Geschrieben am: 30.11.2009 00:10:57

Hallo Bernado,

da du ja bereits per Code die Spalten einfügst, wäre es am einfachsten, du schreibst die Formel für A1 im Code neu rein:

Sub Makro3()
    Columns("C:D").Insert Shift:=xlToRight
    Range("A1").FormulaR1C1 = "=(RC3+RC4)/2"
End Sub


Dann kannst du dir INDIREKT sparen.

Gruß,
Beate


  

Betrifft: AW: INDIREKT mit eingebetter Kalkulation von: Berndt von Uslar Gleichen
Geschrieben am: 30.11.2009 00:22:14

jo, Beate, das wäre eine Möglichkeit. Danke!
Aber gibt es nicht auch eine andere Lösung? Gibt ja unheimlich viele WORKSHEET-Funktionen...
Saludosch
Bernardo


  

Betrifft: Summe mit Bereich.Verschieben von: Beate Schmitz
Geschrieben am: 30.11.2009 00:36:24

Hallo Bernado,

dann vielleicht mit Bereich.Verschieben:

 ABCD
110 515

Formeln der Tabelle
ZelleFormel
A1=SUMME(BEREICH.VERSCHIEBEN(A1;0;2):BEREICH.VERSCHIEBEN(A1;0;3))/2


Guckst Du: Bereich.Verschieben

Gruß,
Beate


  

Betrifft: PS: Summe mit Bereich.Verschieben - Kürzer von: Beate Schmitz
Geschrieben am: 30.11.2009 00:44:22

Kürzer geht es so:

 ABCD
110 515

Formeln der Tabelle
ZelleFormel
A1=SUMME(BEREICH.VERSCHIEBEN(A1;0;2;;2))/2


Gruß,
Beate


  

Betrifft: AW: PS: Summe mit Bereich.Verschieben - Kürzer von: Berndt von Uslar-Gleichen
Geschrieben am: 30.11.2009 01:59:43

genau, daß wäre auch noch eine Möglichkeit. Danke, daß Du noch nach einer Alternative geschaut hast.
Grüße Bernardo


Beiträge aus den Excel-Beispielen zum Thema "INDIREKT mit eingebetter Kalkulation"