Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis mit Makro | Herbers Excel-Forum


Betrifft: Sverweis mit Makro von: Elmar
Geschrieben am: 01.12.2009 22:28:05

Hallo Experten,

ich habe ein Problem, mit eine Verknüpfung / Automatisierung mit dem SVERWEIS.

In der Zelle A2 meiner Tabelle (Name: Datentabelle) gebe ich den Sverweis
=SVERWEIS(B2;Rückstellungen72!$A$1:$M$18151;2;FALSCH) ein. Das ziehe ich dann nach unten und das klappt auch (mit Makro) bestens. Nun suche ich aber nach einer Möglichkeit, dass sich die Formel per Makro selbst baut, also dass der Bereich in der Tabelle "Rückstellungen72" irgendwie automatisch erkannt wird (von A1 bis Mxxxxx) und dann in die Formel (in Zelle A2) übernommen wird. Die (verschiedenen) Tabellen die ich abgleichen muss, haben immer den gleichen Tabellennamen (hier Rückstellungen72) , immer gleich viele Spalten, aber sehr unterschiedlich viele Zeilen (keine Leerzeilen dazwischen) .

Hoffe man kapiert meine Beschreibung....

Danke schon mal

Elmar

  

Betrifft: Dynamischer SVERWEIS() per VBA von: NoNet
Geschrieben am: 01.12.2009 22:51:50

Hallo Elmar,

mit folgender Codezeile kannst Du die SVERWEIS()-Funktion in der aktuellen Zelle dynamisch erstellen :

    ActiveCell.Formula = _
        "=VLookup(B2,Rückstellungen72!" & _
        Sheets("Rückstellungen72").Range("A1").CurrentRegion.Address(, , xlA1) & ",2,0)"

Gruß, NoNet


  

Betrifft: AW: Dynamischer SVERWEIS() per VBA von: Elmar
Geschrieben am: 01.12.2009 23:07:03

Hallo NoNet,

klappt nun wie gewollt, DANKE!!!

Grüße Elmar


Beiträge aus den Excel-Beispielen zum Thema "Sverweis mit Makro"