Microsoft Excel

Herbers Excel/VBA-Archiv

Zusammenfassen von Daten in Pivot | Herbers Excel-Forum


Betrifft: Zusammenfassen von Daten in Pivot von: Micha
Geschrieben am: 08.12.2009 12:22:18

Ich habe das Archiv zwar schon nach dem Thema dursucht, aber keine Lösung für mein Problem gefunden:

Ich möchte die Rohdaten aus folgender Datei (Die Originaldatei mit der ich arbeite ist komplexer für das Beispiel aber nicht relevant):

https://www.herber.de/bbs/user/66430.xlsx

in einer Pivotabelle anzeigen lassen.

In der Pivot möchte ich mir anzeigen lassen, wie viele Kunden an einem Tag aktiv waren.

Wie kann ich das in Pivot herausbekommen?

  

Betrifft: AW: Zusammenfassen von Daten in Pivot von: robert
Geschrieben am: 08.12.2009 12:40:54

hi,

einfach das segment ins datenfeld einfügen

gruß
robert


  

Betrifft: AW: Zusammenfassen von Daten in Pivot von: Andre´
Geschrieben am: 08.12.2009 12:52:02

Hallo Micha,

https://www.herber.de/bbs/user/66432.xlsx

MFG Andre


  

Betrifft: AW: Zusammenfassen von Daten in Pivot von: Micha
Geschrieben am: 08.12.2009 14:13:19

Ich habe mich leider nicht ganz klar ausgedrückt.

Ich möchte, dass in der Pivot pro Tag jeder Nutzer nur einmal gezählt wird.

Derzeit ist es in der Liste so, dass in den Rohdaten jede Transaktion zu einem Eintrag führt.
Da einige Kunden mehrere Transaktionen pro Tag verursachen, möchte ich im Pivot
nur die Anzahl der eindeutigen Kunden und nicht die Anzahl der Transaktionen berechnet haben.

In meiner Tabelle müsste beim 05.11.2009 also "3" angezeigt werden und nicht "4".

Habt Ihr eine Lösung dafür?


  

Betrifft: AW: Zusammenfassen von Daten in Pivot von: Detlef
Geschrieben am: 08.12.2009 14:55:20

Hallo Micha,

ich würde das über eine Hilfsspalte bei den Rohdaten lösen und das als Feld in die Pivot aufnehmen und dann "" unter Feldeigenschaften ausblenden.

Rohdaten

 ABCDE
1DatumKundennummerRechnungsbetragSegmentKunde_1x
205.11.20091315323.000,00A Kunde 
305.11.2009967211.840,00C KundeC Kunde
405.11.200988844782.999,99B KundeB Kunde
505.11.20091315322.690,00A KundeA Kunde
606.11.200955712.415,00A Kunde 
706.11.20091315322.250,00A Kunde 
806.11.200988844781.870,00B KundeB Kunde
906.11.200955711.839,99A Kunde 
1006.11.200955711.950,00A KundeA Kunde
1107.11.200955712.392,50A KundeA Kunde
1208.11.200955711.900,00A KundeA Kunde
1309.11.200988844781.868,99B KundeB Kunde
1409.11.20091315321.935,00A Kunde 
1509.11.200955712.770,00A Kunde 
1609.11.200955712.560,00A KundeA Kunde
1713.11.20091315322.745,00A KundeA Kunde
1814.11.200988844782.890,00B KundeB Kunde
1915.11.20091315322.600,00A KundeA Kunde
2016.11.200988844782.550,00B KundeB Kunde
2117.11.200955711.828,50A KundeA Kunde
2218.11.2009967211.828,40C KundeC Kunde
2319.11.2009967211.840,00C KundeC Kunde
2421.11.2009967211.840,00C KundeC Kunde
2521.11.20091315321.934,50A Kunde 
2621.11.20091315321.840,00A KundeA Kunde

Formeln der Tabelle
ZelleFormel
E2=WENN(SUMMENPRODUKT((A2:A26=A2)*(D2:D26=D2))=1;D2;"")
E3=WENN(SUMMENPRODUKT((A3:A27=A3)*(D3:D27=D3))=1;D3;"")
E4=WENN(SUMMENPRODUKT((A4:A28=A4)*(D4:D28=D4))=1;D4;"")
E5=WENN(SUMMENPRODUKT((A5:A29=A5)*(D5:D29=D5))=1;D5;"")
E6=WENN(SUMMENPRODUKT((A6:A30=A6)*(D6:D30=D6))=1;D6;"")
E7=WENN(SUMMENPRODUKT((A7:A31=A7)*(D7:D31=D7))=1;D7;"")
E8=WENN(SUMMENPRODUKT((A8:A32=A8)*(D8:D32=D8))=1;D8;"")
E9=WENN(SUMMENPRODUKT((A9:A33=A9)*(D9:D33=D9))=1;D9;"")
E10=WENN(SUMMENPRODUKT((A10:A34=A10)*(D10:D34=D10))=1;D10;"")
E11=WENN(SUMMENPRODUKT((A11:A35=A11)*(D11:D35=D11))=1;D11;"")
E12=WENN(SUMMENPRODUKT((A12:A36=A12)*(D12:D36=D12))=1;D12;"")
E13=WENN(SUMMENPRODUKT((A13:A37=A13)*(D13:D37=D13))=1;D13;"")
E14=WENN(SUMMENPRODUKT((A14:A38=A14)*(D14:D38=D14))=1;D14;"")
E15=WENN(SUMMENPRODUKT((A15:A39=A15)*(D15:D39=D15))=1;D15;"")
E16=WENN(SUMMENPRODUKT((A16:A40=A16)*(D16:D40=D16))=1;D16;"")
E17=WENN(SUMMENPRODUKT((A17:A41=A17)*(D17:D41=D17))=1;D17;"")
E18=WENN(SUMMENPRODUKT((A18:A42=A18)*(D18:D42=D18))=1;D18;"")
E19=WENN(SUMMENPRODUKT((A19:A43=A19)*(D19:D43=D19))=1;D19;"")
E20=WENN(SUMMENPRODUKT((A20:A44=A20)*(D20:D44=D20))=1;D20;"")
E21=WENN(SUMMENPRODUKT((A21:A45=A21)*(D21:D45=D21))=1;D21;"")
E22=WENN(SUMMENPRODUKT((A22:A46=A22)*(D22:D46=D22))=1;D22;"")
E23=WENN(SUMMENPRODUKT((A23:A47=A23)*(D23:D47=D23))=1;D23;"")
E24=WENN(SUMMENPRODUKT((A24:A48=A24)*(D24:D48=D24))=1;D24;"")
E25=WENN(SUMMENPRODUKT((A25:A49=A25)*(D25:D49=D25))=1;D25;"")
E26=WENN(SUMMENPRODUKT((A26:A50=A26)*(D26:D50=D26))=1;D26;"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Zusätzlich habe ich dir deine Beispielmappe hochgeladen.

https://www.herber.de/bbs/user/66436.xls

Gruß Detlef


  

Betrifft: AW: Zusammenfassen von Daten in Pivot von: Micha
Geschrieben am: 08.12.2009 16:01:05

Danke Detlef!

Theoretisch ist das die Lösung.
Praktisch für mich leider nicht, da ich mit ca. 250.000 Einträgen arbeite.
Ich habe die Berechnung nach 30 Minuten abgebrochen, da der PC immer noch am rechnen war.

Gibts evtl. noch eine performantere Lösung?


  

Betrifft: AW: Zusammenfassen von Daten in Pivot von: Andre´
Geschrieben am: 08.12.2009 20:43:19

Hallo Micha,
habe auch eine Möglichkeit über Hilfsspalte aber erst bei der Pivot.

https://www.herber.de/bbs/user/66444.xls

Sollte schneller gehen.

MFG Andre


  

Betrifft: AW: Zusammenfassen von Daten in Pivot von: Micha
Geschrieben am: 09.12.2009 09:24:57

Für die Gruppierung nach Kundensegmenten funzt das prima. Danke :-)

Gibt es auch eine Möglichkeit nach eindeutiger Kundennummer zu gruppieren/zu zählen?


Beiträge aus den Excel-Beispielen zum Thema "Zusammenfassen von Daten in Pivot"