Microsoft Excel

Herbers Excel/VBA-Archiv

Formelsuche | Herbers Excel-Forum


Betrifft: Formelsuche von: Pelle
Geschrieben am: 09.12.2009 18:09:04

Tabelle1

 ABCDE
1Y I-II+
2Z 123
3 A-505766
4XA576676
5 A+667687


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Hierfür suche Ich eine Formel, und zwar:

Zuerst den X-Wert. Z.B. A. Dann bin ich in der waagerechten mittleren Spalte (hier 4)
Bisher also 57, 66 oder 76 Punkte.
Dann der Y-Wert. Z.B. I. Dann bin ich in der senkrechten mittleren Spalte (hier D)
Daher nun 66 Punkte.
Zuletzt der Z-Wert. Z.B. 3. Dann bin ich in der senkrechten rechten Spalte (hier E)
Also nun 76 Punkte.

Anderes Beispiel:
X = A-, Y = I- und Z = 3.
D.h., waagerecht die 1. Spalte (hier 3)
Senkrecht dann auch die 1. Spalte (hier C)
Bis jetzt 50 Punkte. Zuletzt Z-Wert. Hier die senkrechte 3. Spalte
Da ich z.Z. in der 1. senkrechten bin, nur ein Schritt nach rechts.
Ergo dann im Ergebnis 57 Punkte.

Wie kann ich das durch eine Formel lösen?

Lieben Dank für Eure Hilfe

Gruss Pelle

  

Betrifft: Erklärungsbedarf... von: Ramses
Geschrieben am: 09.12.2009 18:34:45

Hallo

"...Hier die senkrechte 3. Spalte
Da ich z.Z. in der 1. senkrechten bin, nur ein Schritt nach rechts...:"

Warum bitte den Wert aus der 2. Spalte und nciht aus der 3. Spalte ?

Gruss Rainer


  

Betrifft: AW: Erklärungsbedarf... von: Pelle
Geschrieben am: 09.12.2009 18:41:07

Hi Ramses,

weil nicht von ganz links nach ganz rechts gesprungen werden kann.
Immer nur max ein Schritt nch rechts


  

Betrifft: AW: Erklärungsbedarf... von: Ramses
Geschrieben am: 09.12.2009 18:43:21

Hallo

"...weil nicht von ganz links nach ganz rechts gesprungen werden kann..."

Dann macht die Spalten-/Zahlenangabe keinen Sinn. Dann kannst du ja gleich immer den Wert aus der Nachbarzelle nehmen !?

Gruss Rainer


  

Betrifft: AW: Erklärungsbedarf... von: Pelle
Geschrieben am: 09.12.2009 18:52:51

Dann dafür die Formel bitte.


  

Betrifft: Lösung ? von: Ramses
Geschrieben am: 09.12.2009 19:57:51

Hallo

meinst du so ?

Tabelle2

 ABCDEF
1Y I-II+ 
2Z 123 
3 A-505766 
4XA576676 
5 A+667687 
6      
7      
8      
9Gesucht     
10XA-     
11YI-     
12Z3     
13Ergebnis57    
14      

Formeln der Tabelle
ZelleFormel
B13=INDEX(C3:E5;VERGLEICH(RECHTS(A10;LÄNGE(A10)-1); B3:B5;0); WENN(UND((RECHTS(A12;LÄNGE(A12)-1)*1)=VERGLEICH(RECHTS(A11;LÄNGE(A11)-1); C1:E1;0); ODER(1;3)); VERGLEICH(RECHTS(A11;LÄNGE(A11)-1); C1:E1;0); WENN((RECHTS(A12;LÄNGE(A12)-1)*1)<VERGLEICH(RECHTS(A11;LÄNGE(A11)-1); C1:E1;0); VERGLEICH(RECHTS(A11;LÄNGE(A11)-1); C1:E1;0)-1;VERGLEICH(RECHTS(A11;LÄNGE(A11)-1); C1:E1;0)+1)))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruss Rainer


  

Betrifft: AW: Lösung ? von: Pelle
Geschrieben am: 10.12.2009 08:58:35

Moin Rainer,

vielen Dank für deine Formel.
Ich werde sie im Laufe des Tages testen und dann nocheinmal eine Rückmeldung geben.

Bis dahin einen schönen Tag

Gruß Pelle