Microsoft Excel

Herbers Excel/VBA-Archiv

Datumswerte vergleichen bei untersch. Formaten | Herbers Excel-Forum


Betrifft: Datumswerte vergleichen bei untersch. Formaten von: Nicole
Geschrieben am: 10.12.2009 09:24:10

Guten Morgen,

ich möchte zwei Datumsfelder vergleichen. Das Problem ist, dass ein Datum ein Textformat hat:
200912 (als Text)
und das andere ein Datum als Datumsformat:
tt.mm.jj (10.12.09)

Wie schaffe ich es, diese über den Monat und das Jahr zu vergleichen in VBA?

Vielen Dank schon im voraus.
Nicole

  

Betrifft: AW: Datumswerte vergleichen bei untersch. Formaten von: ede
Geschrieben am: 10.12.2009 09:28:54

Hallo Nicole,
du kannstper Formel dein Datum in Text umwanden und dan mit dem anderen vergleichen!
schau mal in den funktionen nach text(), monat() jahr().

gruss


  

Betrifft: AW: Datumswerte vergleichen bei untersch. Formaten von: Hajo_Zi
Geschrieben am: 10.12.2009 09:32:34

Hallo Nicole,

es muss nicht alles über VBA gelöst werden.

Tabelle2

 CDE
2420091210.12.09Gleich
2520091311.12.09Ungleich

verwendete Formeln
Zelle Formel
E24 =WENN(UND(JAHR(D24)=LINKS(C24;4)*1;MONAT(D24)=RECHTS(C24;2)*1);"Gleich";"Ungleich")
E25 =WENN(UND(JAHR(D25)=LINKS(C25;4)*1;MONAT(D25)=RECHTS(C25;2)*1);"Gleich";"Ungleich")

Tabellendarstellung in Foren Version 4.31


GrußformelHomepage


  

Betrifft: =TEXT(A2;"0000-00")=TEXT(B2;"JJJJ-MM") owT von: Rudi Maintaire
Geschrieben am: 10.12.2009 09:53:36




  

Betrifft: ich Trottel: =A2=TEXT(B2;"JJJJMM") owT von: Rudi Maintaire
Geschrieben am: 10.12.2009 10:39:12




  

Betrifft: AW: ich Trottel: =A2=TEXT(B2;"JJJJMM") owT von: Nicole
Geschrieben am: 10.12.2009 11:18:13

danke erst einmal für die Lösung. Was ich Dussel natürlich vergessen habe zu sagen: die Daten werden automatisiert eingespielt, da sich diese immer ändern. Darum wird vorher alles gelöscht. So können ja auch leider die Formeln nicht gehalten werden.
So komm ich um VBA wohl nicht drumrum.


  

Betrifft: AW: ich Trottel: =A2=TEXT(B2;"JJJJMM") owT von: Hajo_Zi
Geschrieben am: 10.12.2009 11:20:35

Hallo Nicole,

die Spalte mit den Formeln baucht doch nicht gelöscht werden.

Gruß Hajo


  

Betrifft: Formel per VBA von: Rudi Maintaire
Geschrieben am: 10.12.2009 11:27:19

Hallo,
dann füge auch die Formel per Code ein.
JJJJMM in A, Datum in B, Formel in C.

Sub FormelRein()
  With Sheets(1)
  .Range(.Cells(2, 1), .Cells(Rows.Count, 1).End(xlUp)).Offset(, 2).FormulaR1C1 = _
    "=RC[-2]=TEXT(RC[-1],""JJJJMM"")"
  End With
End Sub

Gruß
Rudi


  

Betrifft: AW: ich Trottel: =A2=TEXT(B2;"JJJJMM") owT von: Nicole
Geschrieben am: 10.12.2009 11:43:40

dankeschön euch beiden für die Mühe.
Geht jetzt.
Nicole


Beiträge aus den Excel-Beispielen zum Thema "Datumswerte vergleichen bei untersch. Formaten"