Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMENPRODUKT o.ä? | Herbers Excel-Forum


Betrifft: SUMMENPRODUKT o.ä? von: Peter
Geschrieben am: 17.12.2009 21:38:15

Guten Abend

Ich habe eine Datentabelle A1:H16 und möchte auf jeder Zeile in Spalte G den Wert ausweisen, der sich ergibt, wenn alle Spaltenwerte C, D und F pro Zeile multipliziert werden und der Wert, der sich ergibt, wenn C, E und F pro Zeile mulitipliziert werden, subtrahiert wird. In der Summe dürfen jedoch nur Zeilenwerte berücksichtigt werden, bei denen in Spalte A der gleiche String steht.

Sorry, das ist eine (zu) komplizierte Beschreibung. Deshalb habe ich dies in einer Beispieltabelle abgebildet. In Spalte G sind im Moment die gesuchten Werte manuell eingetragen. Mit welcher Formel kann ich diese berechnen? Habe mal mit SUMMENPRODUKT versucht, bin dann aber gescheitert.

Danke für jede Hilfe.

Gruss, Peter

https://www.herber.de/bbs/user/66682.xls

  

Betrifft: AW: SUMMENPRODUKT o.ä? von: Beate Schmitz
Geschrieben am: 17.12.2009 22:10:24

Hallo Peter,

 ABCDEFGHI
1Wert1Wert2Wert3Wert4Wert5Wert6Wert7Wert8 
2ABC11,0000101,85780.324,810,00 
3ABC21,5100101,03780.324,810,00 
4ABC31,0000100,93780.324,810,00 
5ABC41,0026430100,66780.324,81266.044,38 
6ABC51,514571144107,73780.324,81720.150,27 
7ABC61,0001914107,56780.324,81-205.869,84 
8ABC71,0000107,69780.324,810,00 
9ABC81,0000107,36780.324,810,00780.324,81
10DEF11,000094,79308407,460,00 
11DEF21,000170094,45308407,46-160.565,00 
12DEF31,513300094,45308407,46471.033,96 
13DEF41,510091,03308407,460,00 
14DEF51,5101590,94308407,46-2.061,50 
15DEF61,510090,73308407,460,00 
16DEF71,5100100,72308407,460,00 
17DEF81,510099,29308407,460,00308.407,46

Formeln der Tabelle
ZelleFormel
I2=(WENN(A2=A3;"";SUMME(H$2:H2)-SUMME(I$1:I1)))


Die Formel aus I2 kannst du runterkopieren.

Gruß,
Beate


  

Betrifft: AW: SUMMENPRODUKT o.ä? von: Peter
Geschrieben am: 17.12.2009 22:16:05

Hallo Beate
Danke für diesen Lösungsansatz.

Nun ist es so, dass Spalten H und I Hilfspalten sind, die ich nur zum Aufzeigen der gewünschten Werte darstellte. Ich sollte eine Möglichkeit haben, die Werte ohne Umweg über Saplte H und I zu ermitteln.

Eine "direkte" Lösung wäre sehr willkommen.

Gruss, Peter


  

Betrifft: AW: SUMMENPRODUKT o.ä? von: Josef Ehrensberger
Geschrieben am: 17.12.2009 22:34:34

Hallo Peter,

Tabelle1

 ABCDEFG
1ABC11,0000101,85  
2ABC21,5100101,03  
3ABC31,0000100,93  
4ABC41,0026430100,66  
5ABC51,514571144107,73  
6ABC61,0001914107,56  
7ABC71,0000107,69  
8ABC81,0000107,36 780.324,81
9DEF11,000094,79  
10DEF21,000170094,45  
11DEF31,513300094,45  
12DEF41,510091,03  
13DEF51,5101590,94  
14DEF61,510090,73  
15DEF71,5100100,72  
16DEF81,510099,29 308.407,46

Formeln der Tabelle
ZelleFormel
G1=WENN(ZÄHLENWENN($A$1:$A$16;A1)=ZÄHLENWENN($A$1:A1;A1); SUMMENPRODUKT(($A$1:$A$16=A1)*($C$1:$C$16)*($D$1:$D$16)*($F$1:$F$16))-SUMMENPRODUKT(($A$1:$A$16=A1)*($C$1:$C$16)*($E$1:$E$16)*($F$1:$F$16)); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: AW: SUMMENPRODUKT o.ä? von: Peter
Geschrieben am: 17.12.2009 22:56:05

Hallo Sepp
Vielen Dank! das bringt mich auf die Lösung. Wenn ich ja die 780'324.81 schon ab Zeile 2 und die 308'407.46 schon ab Zeile 9 haben will, lasse ich einfach die Bedingung "Zahlenwenn" weg.
Gruss, Peter