Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Woche ermitteln

Woche ermitteln
Walter
Hallo,
ich möchte gern die Woche ermitteln.
Habe die Formel gefunden, leider klappt es nicht RICHTIG.
=KÜRZEN((A12-WOCHENTAG(T13;2)-DATUM(JAHR($B$1+4-WOCHENTAG(T13;2));1;-10))/7)
Mein Jahr steht immer in "B1" (01.01.2010)
Der Monat als Zahl immer in "E1"
Der aktuelle Tag also Montag in "M13" oder "T13" u. AA13 z.b.
was muß ich ändern ?
mfg walter mb

13
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
verstehe ich nicht...
18.12.2009 11:55:15
Björn
Hallo,
warum benutzt du 3 Felder?
Nimm doch 1 DAtumsfeld, wende darauf die Formel für die Woche an und auch alle anderen holst du dir per Formel bzw. Formatierung aus diesem 1 Feld.
Gruß
BJörn B.
AW: verstehe ich nicht...
18.12.2009 12:11:18
ptonka
Hallo,
ich habe dies in einem Beispiel realisiert.
In Spalte A stehen die Daten in der Form TT.MM.JJJJ von 01.01.2009 bis beliebig untereinander.
In Spalte B steht folgende Formel:
=WENN(WOCHENTAG(A1;2)=1;((A1-DATWERT("01.01."&JAHR(A1)))/7)+1;"")
Hier wird bei Beginn einer neuen Woche (immer Montags [Wochentag = 1]) die KW in Spalte B angezeigt.
Das funktioniert. Vielleicht kannst Du diese Formel für Dich entsprechend abwandeln.
Gruß,
Ptonka
Anzeige
AW: verstehe ich nicht...
18.12.2009 13:14:25
Walter
Hallo BJörn,
habe mal mein Muster geschickt.
mfg walter mb
AW: Woche ermitteln
18.12.2009 13:40:16
Bernd
Hallo Walter,
Warum nimmst Du nicht die Funktion KALENDERWOCHE() ?
z.B. in Zelle A1 deine Verkettung
=M13 & "." & E1 & "." & B1
=KALENDERWOCHE(DATUM(A1);2)
Gruß
Bernd
Fehler, "zu wenige Argumente"
18.12.2009 13:45:35
Walter
Hallo Bernd,
leider Fehlermeldung.
mfg Walter MB
AW: Fehler, "zu wenige Argumente"
18.12.2009 14:07:34
ptonka
Hallo Walter,
ich habe mir Dein Muster mal angesehen.
Nimm mal folgenden Code:
=KALENDERWOCHE(TEXT(VERKETTEN(TAG(H1);E1;JAHR(B1));"TT.MM.JJJJ"))
Gruß,
Ptonka
Anzeige
Sorry - kleine Korrektur
18.12.2009 14:19:25
ptonka
Sorry,
die richtige Formel lautet:
=KALENDERWOCHE(TEXT(VERKETTEN(TAG(H1);".";E1;".";JAHR(B1));"TT.MM.JJJJ"))
Gruß,
Ptonka
Kannst Du mir mal das Muster schicken ?
18.12.2009 14:23:41
Walter
Hallo Ptonka,
kannst Du mir mal das Muster schicken ?
mfg walter mb
Danke Frohes Fest ... -)
20.12.2009 13:19:00
walter
Hallo Ptonka,
danke für die geduldige Unterstützung,
schönes Weihnachtsfest u. ein gesundes neues JAHR !
mfg walter MB
AW: Fehler, "zu wenige Argumente"
18.12.2009 14:19:41
Walter
Hallo Ptonka,
wie hast Du es geschafft ?
Habe Deine Formel in F11 gesetzt das gleiche wie in M11,
bei mir kommt #Name?
mfg Walter
Anzeige
Fehler das gleiche wie in Korrektur
18.12.2009 14:21:45
Walter
mfg walter mb

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige