Microsoft Excel

Herbers Excel/VBA-Archiv

Toleranzwerte in Excel 2000 | Herbers Excel-Forum


Betrifft: Toleranzwerte in Excel 2000 von: Thomas
Geschrieben am: 21.12.2009 15:59:30

Hallo,

habe da ein Problem mit Toleranzen.

Zur Zeit verwende ich die Formel

WENN(AM5<=1000;AM5/100;AM5/200)

jetzt ist es aber so das der Wert in AM5 etwas anders aussieht bzw. sehen kann.

Beispiel
0-1000 = +1%
1000+ = +0,5%

oder ganz Abstrakt

0-1000 = +6/-0mm
1000-2000 = +10/-0mm
2000+ = 0,5%/-0%

Mit meiner Formel komme ich dem ersten Beispiel ja nah aber bei der zweiten wo ich einmal in "mm" dann in "%" rechnen muss komme ich nicht mehr mit. Kann mir da einer vielleicht ein paar kleine Tipps geben?

Vielen Dank
Thomas

  

Betrifft: AW: Toleranzwerte in Excel 2000 von: werni
Geschrieben am: 21.12.2009 16:51:13

Hi Thomas

Ganz kapiert habe ichs eigentlich nicht, aber ein Versuch trotzdem gestartet.
https://www.herber.de/bbs/user/66751.htm

Gruss Werner


  

Betrifft: AW: Toleranzwerte in Excel 2000 von: fcs
Geschrieben am: 21.12.2009 17:02:37

Hallo Thomas,

das geht zum Beispiel so:

=WENN(AMS>=0;((AMS>0)*(AMS<=1000)*6)+((AMS>1000)*(AMS<=2000)*10)+
((AMS>2000)*0,5/100*AMS);"???")

zum Verständnis: das ist gleichbedeutend mit

=WENN(AMS>=0;WENN(UND(AMS>0;AMS<=1000);6;0)+WENN(UND(AMS>1000;AMS<=2000);10;0)
+WENN(AMS>2000;0,5/100*AMS;0);"???")

Gruß
Franz


  

Betrifft: AW: Toleranzwerte in Excel 2000 von: BoskoBiati
Geschrieben am: 21.12.2009 19:38:57

Hallo,

oder so:

Tabelle1

 AB
1100106
210001006
310011011
420002020
530003025
6 0

Formeln der Tabelle
ZelleFormel
B1=A1+((A1<=1000)*6+(A1>1000)*10+(A1>=2000)*(A1*0,005))*(A1<>0)
B2=A2+((A2<=1000)*6+(A2>1000)*10+(A2>=2000)*(A2*0,005))*(A2<>0)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


  

Betrifft: AW: Toleranzwerte in Excel 2000 von: Thomas
Geschrieben am: 22.12.2009 09:18:01

Ich muss mich Entschuldigen. Aber diese doppelt und dreifach Posting von mir war ein Fehler von mir. Ich habe wohl die Refresh Taste des IE zu oft betätigt und er hat mir dann immer einen neuen Post gesetzt.
Bitte um löschen der doppel Postings.

Und Entschuldigung noch mal!!!

Gruss,
Thomas