Microsoft Excel

Herbers Excel/VBA-Archiv

SVERWEIS & WENN abfrage verbinden | Herbers Excel-Forum


Betrifft: SVERWEIS & WENN abfrage verbinden von: Heinz H
Geschrieben am: 28.12.2009 19:18:08

Hallo Leute im Forum

Möchte untere Formel verbinden.
Also in A10 steht das Datum. In W64:W81 steht das Datum wenn dieses übereinstimmt,dann in G10 gleich ""
In B 10 steht der Wochentag.

Könnte mir bitte jemand helfen ?

Gruß
Heinz

=SVERWEIS(A10;$W$64:$X$81;2;0);WENN(WOCHENTAG(B10)=2;$E$43;"")

  

Betrifft: AW: SVERWEIS & WENN abfrage verbinden von: Ramses
Geschrieben am: 28.12.2009 21:13:56

Hallo

Die Formel und deine Erklärung ergibt keinen Sinn.
Kannst du mal ein Beispiel hochstellen wie das aussehen soll ?

Gruss Rainer


  

Betrifft: AW: SVERWEIS & WENN abfrage verbinden von: Heinz H
Geschrieben am: 29.12.2009 07:18:10

Hallo Rainer

Hier das Beispiel.
Danke Heinz

https://www.herber.de/bbs/user/66863.xls


  

Betrifft: AW: SVERWEIS & WENN abfrage verbinden von: hary
Geschrieben am: 29.12.2009 08:24:14

Hallo Heinz
Teste mal. Formel inG30. Ist Kopierbar.

=WENN(ISTFEHLER(VERGLEICH(A30;$W$64:$W$81;0));WENN(WOCHENTAG(B30)=2;$E$43;WENN(WOCHENTAG(B30)=3; _
$E$44;WENN(WOCHENTAG(B30)=4;$E$45;WENN(WOCHENTAG(B30)=5;$E$46;WENN(WOCHENTAG(B30)=6;$E$47;"")))));"")

gruss hary


  

Betrifft: AW: SVERWEIS & WENN abfrage verbinden von: Heinz H
Geschrieben am: 29.12.2009 08:27:58

Guten morgen,Hary

Genau so !!

Recht herzlichen DANK !!

Gruß
Heinz


  

Betrifft: AW: bitte owT. von: hary
Geschrieben am: 29.12.2009 08:31:40

.


  

Betrifft: AW: etwas kürzer von: hary
Geschrieben am: 29.12.2009 08:56:45

Hallo Heinz
ich nochmal.
Teste mal. Formel G7. Kopierbar

=WENN(ISTFEHLER(VERGLEICH(A7;$W$64:$W$81;0));WENN(A7="";"";INDEX($G$43:$G$47;VERGLEICH(TEXT(B7;" _
tttt");$A$43:$A$47;0)));"")

Gruss hary


  

Betrifft: AW: etwas kürzer von: Heinz H
Geschrieben am: 29.12.2009 09:20:33

Hallo Hary

Echt super !!!

Danke,Heinz


  

Betrifft: AW: etwas kürzer von: BoskoBiati
Geschrieben am: 29.12.2009 12:44:34

Noch etwas kürzer:

=WENN(ISTFEHLER(VERGLEICH(A30;$W$64:$W$81;0));WENN(A30="";"";INDIREKT("E"&WOCHENTAG(B30)+41)))
Gruß

Bosko


  

Betrifft: AW: etwas kürzer von: Heinz H
Geschrieben am: 29.12.2009 16:43:50

Hallo Bosko

So bekomme ich aber einen Fehler in G30

Gruß Heinz

01.10.2004

 ABCDEFGHIJKLMNO
3026.10.2004Fr    FALSCH    Nationalfeiertag   

Formeln der Tabelle
ZelleFormel
G30=WENN(ISTFEHLER(VERGLEICH(A30;$W$64:$W$81;0)); WENN(A30="";"";INDIREKT("E"&WOCHENTAG(B30)+41)))
L30=WENN(ISTFEHLER(SVERWEIS(A30;$W$64:$X$81;2;0)); "";SVERWEIS(A30;$W$64:$X$81;2;0))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


  

Betrifft: AW: etwas kürzer von: BoskoBiati
Geschrieben am: 29.12.2009 17:15:12

Hallo,

war mein Fehler. Habe etwas unterschlagen:

=WENN(ISTFEHLER(VERGLEICH(A30;$W$64:$W$81;0));WENN(A30="";"";INDIREKT("E"&WOCHENTAG(B30)+41));"") 

Habe nur mit calc getestet, da kommt kein Fehler.

Gruß

Bosko


  

Betrifft: AW: etwas kürzer von: Heinz H
Geschrieben am: 29.12.2009 17:18:43

Hallo Bosko

Danke - Jetzt passt es zu 100%

Gruß
Heinz


Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS & WENN abfrage verbinden"