Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenn mit 2 Bedingungen, aber Text | Herbers Excel-Forum


Betrifft: Zählenwenn mit 2 Bedingungen, aber Text von: Jack
Geschrieben am: 12.01.2010 10:43:11

Hallo zusammen,

ich habe da ein Problem, was für die Profis unter euch sicherlich leicht zu lösen ist, mir aber seit gestern Abend Kopfzerbrechen bereitet:

Wie in der Überschrift beschrieben, möchte ich, dass in einem definiertem Feld ein Zählung vorgenommen wird, sofern die Kombination 2 bestimmter Begriffe in 2 anderen Feldern auftaucht...

also zum Beispiel eine Spalte mit Ländern und die andere Spalte mit Industrien

Jetz soll bitte ausgezählt werden wie oft die Kombination Germany in der Spalte Länder und sagen wir Power Plants in der Spalte Industrien vorkommt...

Ich hoffe mein Problem wurde ungefähr verstanden, habe auch nochmal ein file hochgeladen, um es etwas deutlicher zu machen...

https://www.herber.de/bbs/user/67158.xls

Vielen Dank schonmal!

Gruß,
Jack

  

Betrifft: AW: Zählenwenn mit 2 Bedingungen, aber Text von: Hajo_Zi
Geschrieben am: 12.01.2010 10:45:52

Hallo Jack,

benutze SUMMENPRODUKT()
http://hajo-excel.de/chCounter3/getfile.php?id=137

GrußformelHomepage


  

Betrifft: AW: Zählenwenn mit 2 Bedingungen, aber Text von: Jack
Geschrieben am: 12.01.2010 11:07:11

Vielen dank für die antwort - es hat geklappt, zwar nicht so wie bei dir, aber dadurch hab ich den entscheidenen Denkanstoß bekommen!

ich wusste nicht, dass man nochmal *1 hinter dir klammer machen muss!

Gruß,
Jack


  

Betrifft: AW: Zählenwenn mit 2 Bedingungen, aber Text von: Jockel
Geschrieben am: 12.01.2010 11:56:46

hi Jack, wie kommst du darauf? musst du nicht..!!!


Overview of Interviews (2)

 BCDEFGHIJ
2                 
3  Country  GermanyUKScandinaviaBenelux  Total
4Industry     
5                 
6Power Plants    3003  6
7Chemical    0220  4
8Gas and Oil    2110  4
9                 
10Total    5333  14
11                 
12                 
13                 
14                 
15                 
16                 
17                 
18                 
19CountryIndustry             
20GermanyPower Plants             
21UKChemical             
22ScandinaviaGas and Oil             
23BeneluxPower Plants             
24GermanyGas and Oil             
25BeneluxPower Plants             
26UKChemical             
27GermanyPower Plants             
28GermanyGas and Oil             
29BeneluxPower Plants             
30UKGas and Oil             
31ScandinaviaChemical             
32ScandinaviaChemical             
33GermanyPower Plants             

verbundene Zellen
E3:E4
F3:F4
G3:G4
H3:H4
J3:J4

verwendete Formeln
Zelle Formel
E6 =SUMMENPRODUKT(($B$20:$B$33=E$3)*($C$20:$C$33=$B6))
J6 =SUMME(E6:H6)
J7 =SUMME(E7:H7)
J8 =SUMME(E8:H8)
E10 =SUMME(E4:E8)
F10 =SUMME(F4:F8)
G10 =SUMME(G4:G8)
H10 =SUMME(H4:H8)
J10 =SUMME(J4:J8)

Tabellendarstellung in Foren Version 5.3





cu jörg eine rückmeldung wäre ganz reizend


Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn mit 2 Bedingungen, aber Text"