Microsoft Excel

Herbers Excel/VBA-Archiv

Aufbereitung Liste | Herbers Excel-Forum


Betrifft: Aufbereitung Liste von: Bernd
Geschrieben am: 12.01.2010 11:32:41

Hallo,

ich würde gerne eine Liste, die blockweise aufgebaut ist, gerne automatisch auswerten. Meine bisherige Lösung funktioniert zwar auch, ist aber eher umständlich und gefällt mir immer weniger.

Deshalb habe ich nun eine Mustervorlage mit hoffentlich ausreichenden Erläuterungen hochgeladen, die sich auf das Wesentliche beschränkt:

https://www.herber.de/bbs/user/67164.xls

Beste Grüße
Bernd

  

Betrifft: AW: Aufbereitung Liste von: Detlef
Geschrieben am: 12.01.2010 12:18:37

Hallo Bernd,

vielleicht so.

Tabelle1

 ABCDEFGHIJK
1       AnfangsdatumEnddatumZIEL 
2       01.10.200931.12.2009  
3     Auswertungszeitraum     
4GeschäftsnummerAbschlussdatumName Ertrag    Ertrag (saldiert)Name Kunde
578022201.10.2009Händler AA10      
678022215.10.2009Händler AA-5    18Kunde A
778022216.10.2009Kunde AA10      
878022202.10.2009Kunde AA15      
978022203.10.2009Händler AA-12      
1078055514.09.2009Händler BB42      
1178055501.09.2009Kunde BB-45      
1278055520.09.2009Kunde BB12      
1378055501.09.2009Kunde BB-5      
1478055501.09.2009Kunde BB5    0Kunde B
1578055515.09.2009Händler BB16      
1678055501.09.2009Händler BB5      
1783055501.09.2009Kunde CC-15      
1883055515.09.2009Händler CC-41      
1983055515.10.2009Händler CC10      
2083055516.10.2009Händler CC-12      
2183055501.11.2009Kunde CC12    -36Kunde C
2283055514.09.2009Kunde CC10      
2398055501.10.2009Kunde DD10      
2498055501.10.2009Händler DD-15    35Kunde D
2598055501.11.2009Händler DD20      
2698055522.10.2009Kunde DD10      
2798055501.10.2009Händler DD10      
2898522201.12.2009Händler EE-66      
2998522201.12.2009Kunde EE44      
3098522215.12.2009Händler EE10      
3198522216.12.2009Händler EE-11    -13Kunde E
3298522214.12.2009Händler EE10      

Formeln der Tabelle
ZelleFormel
D5=RECHTS(C5;1)
D6=RECHTS(C6;1)
J6=SUMMENPRODUKT(($D$5:$D$32=RECHTS(K6;1))*($B$5:$B$32>=$H$2)*($B$5:$B$32<=$I$2)*($E$5:$E$32))
D7=RECHTS(C7;1)
D8=RECHTS(C8;1)
D9=RECHTS(C9;1)
D10=RECHTS(C10;1)
D11=RECHTS(C11;1)
D12=RECHTS(C12;1)
D13=RECHTS(C13;1)
D14=RECHTS(C14;1)
J14=WENN(SUMMENPRODUKT(($D$5:$D$32=RECHTS(K14;1))*($B$5:$B$32>=$H$2)*($B$5:$B$32<=$I$2)*($E$5:$E$32))<>0;SUMMENPRODUKT(($D$5:$D$32=RECHTS(K14;1))*($E$5:$E$32)); 0)
D15=RECHTS(C15;1)
D16=RECHTS(C16;1)
D17=RECHTS(C17;1)
D18=RECHTS(C18;1)
D19=RECHTS(C19;1)
D20=RECHTS(C20;1)
D21=RECHTS(C21;1)
J21=WENN(SUMMENPRODUKT(($D$5:$D$32=RECHTS(K21;1))*($B$5:$B$32>=$H$2)*($B$5:$B$32<=$I$2)*($E$5:$E$32))<>0;SUMMENPRODUKT(($D$5:$D$32=RECHTS(K21;1))*($E$5:$E$32)); 0)
D22=RECHTS(C22;1)
D23=RECHTS(C23;1)
D24=RECHTS(C24;1)
J24=WENN(SUMMENPRODUKT(($D$5:$D$32=RECHTS(K24;1))*($B$5:$B$32>=$H$2)*($B$5:$B$32<=$I$2)*($E$5:$E$32))<>0;SUMMENPRODUKT(($D$5:$D$32=RECHTS(K24;1))*($E$5:$E$32)); 0)
D25=RECHTS(C25;1)
D26=RECHTS(C26;1)
D27=RECHTS(C27;1)
D28=RECHTS(C28;1)
D29=RECHTS(C29;1)
D30=RECHTS(C30;1)
D31=RECHTS(C31;1)
J31=WENN(SUMMENPRODUKT(($D$5:$D$32=RECHTS(K31;1))*($B$5:$B$32>=$H$2)*($B$5:$B$32<=$I$2)*($E$5:$E$32))<>0;SUMMENPRODUKT(($D$5:$D$32=RECHTS(K31;1))*($E$5:$E$32)); 0)
D32=RECHTS(C32;1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

https://www.herber.de/bbs/user/67170.xls

Die Hilfsspalte D kannst Du ja ausblenden.

Gruß Detlef


  

Betrifft: AW: Aufbereitung Liste von: Bernd
Geschrieben am: 12.01.2010 13:30:14

Hallo Detlef,

zunächst Danke für Deine Lösung! Ich muß aber nochmal nachhaken: Die Formeln in Spalte J sind doch manuell einzusetzen, d.h. man kann die nicht einfach so "runterziehen". Der Name in Spalte K wird in Deiner Lösung auch nicht ermittelt, sondern muß manuell eingegeben werden. Die Ertragsermittlung habe ich meiner alten Lösung auch so hinbekommen. Probleme tun sich eher bei den Spalten J und K auf.

Gruß
Bernd


  

Betrifft: AW: Aufbereitung Liste von: Detlef
Geschrieben am: 12.01.2010 15:03:45

Hallo Bernd,

so ganz verstehe ich noch nicht was Du erreichen willst. Die Ertragsformel in Spalte J steht für mich an nicht nachvollziehbarer Stelle (mal in der 2., mal in der 5. Zeile eines Blocks).

Da fehlt mir im Moment die klare Struktur. Man könnte es z.B. immer in die 1. Zeile eines Blocks schreiben, wenn der Blockinhalt wechselt. Dann könntest Du das auch runterkopieren. Die Spalte K könnte man entsprechend dynamisch anpassen.

Gruß Detlef


  

Betrifft: AW: Aufbereitung Liste von: Bernd
Geschrieben am: 12.01.2010 21:16:50

Hallo Detlef,

das saldierte Ergebnis sollte in der Zeile des jeweiligen Blocks augewiesen werden, die das höchste Abschlussdatum aufweist (bei mehreren gleichen Dati kann irgendeines davon gewählt werden). Letztendes soll aus diesem Block quasi das Ergebnis ausgelesen werden in Kombination mit Kundennamen und höchstem Eingabedatum. Da die einzelnen Werte aber nicht aller in einer Zeile stehen, habe ich diese Anfrage gestellt. Im Prinzip kann auch die erste Zeile jedes Blockes als Ausgabezeile des Ergebnis gewählt werden, dann brauche ich aber trotzdem das höchste Eingabedatum und den Kundennamen in dieser Zeile.
Ich weiß nicht was einfacher ist, aber ich hoffe, mein Wunsch ist nun eindeutiger. Sorry, die Liste ist leider so vorgegeben, da kann ich nicht daran ändern.

Viele Grüße
Bernd