Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Image
BildScreenshot zu Image Image-Seite mit Beispielarbeitsmappe aufrufen

Wenn-Funktion in Kombination mit Länge bzw. Oder | Herbers Excel-Forum


Betrifft: Wenn-Funktion in Kombination mit Länge bzw. Oder von: Peter Mikschovsky
Geschrieben am: 12.01.2010 12:38:10

hallo liebe Teilnehmer

sollte ich den betreffenden Thread bzw. dessen Lösung dennoch übersehen haben, ersuche ich hier um Angabe des Links.

Meine Anforderung sieht folgendermaßen aus:
Es gibt nachfolgende Mustertabelle (die Spalte ist als TEXT formatiert und soll auch so bleiben, da es sich dabei um Österr. und deutsche PLZ, welche mit 0 beginnen können, handelt)

SpalteA SpalteB SpalteC
PLZ Destination Länge
4020 Österreich 4
5020 Österreich 4
6020 Österreich 4
7000 Österreich 4
1020 Österreich 4
1030 Österreich 4
1040 Österreich 4
01256 Ausland 5
02560 Ausland 5
19520 Ausland 5
89510 Ausland 5
25632 Ausland 5
4005 Ausland 4
5005 Ausland 4
6005 Ausland 4
1005 Ausland 4

in den angrenzenden Spalte B sollte dann "Ausland" stehen, wenn in Spalte A 5-stellige PLZ oder 4005, 5005, 6005 oder 1005 stehen. Die restlichen Einträge der Spalte B mit 4-stelligen PLZ sollten dann "Österreich" sein.

Leider bekomm ich es nur über die "Hilfsspalte" C derzeit hin, daß das richtige Ergebnis in Spalte B aufscheint. Diese Hilfsspalte möchte ich aber am liebsten gar nicht brauchen.

Die Formel in B2 lautet:
WENN(ODER(A2="1005";A2="4005";A2="5005";A2="6005";C2=5);"Ausland";"Österreich")

Die Formel in C2 lautet derzeit:
LÄNGE(A2)

Wie schafft man es also die Formel "Länge(A2)" in die bestehende Wenn-Formel zu integrieren und trotzdem zum richtigen Ergebnis zu kommen.

Ich danke euch schon mal im Voraus
Peter

  

Betrifft: AW: Wenn-Funktion in Kombination mit Länge bzw. Oder von: Rudi Maintaire
Geschrieben am: 12.01.2010 12:44:12

Hallo,
ganz einfach
WENN(ODER(A2={"1005"."4005"."5005"."6005"};Länge(A2)=5);"Ausland";"Österreich")

Level?

Gruß
Rudi


  

Betrifft: AW: Wenn-Funktion in Kombination mit Länge bzw. Oder von: Josef Ehrensberger
Geschrieben am: 12.01.2010 12:44:59

Hallo Peter,

"Excel gut" ?

WENN(ODER(A2="1005";A2="4005";A2="5005";A2="6005";LÄNGE(A2)=5);"Ausland";"Österreich")

Gruß Sepp



  

Betrifft: AW: Wenn-Funktion in Kombination mit Länge bzw. Oder von: Peter Mikschovsky
Geschrieben am: 12.01.2010 12:59:25

Danke an alle beide!! Da hat mir irgendwo was gefehlt ;-)


  

Betrifft: AW: Wenn-Funktion in Kombination mit Länge bzw. Oder von: Klaus-Dieter
Geschrieben am: 12.01.2010 12:48:52

Hallo Peter,

versuche es einmal so:

Tabelle1

 AB
1PLZDestination
24020Österreich
35020Österreich
46020Österreich
57000Österreich
61020Österreich
71030Österreich
81040Österreich
91256Österreich
102560Österreich
1119520Ausland

Formeln der Tabelle
ZelleFormel
B2=WENN(LÄNGE(A2)=4;"Österreich";"Ausland")
B3=WENN(LÄNGE(A3)=4;"Österreich";"Ausland")
B4=WENN(LÄNGE(A4)=4;"Österreich";"Ausland")
B5=WENN(LÄNGE(A5)=4;"Österreich";"Ausland")
B6=WENN(LÄNGE(A6)=4;"Österreich";"Ausland")
B7=WENN(LÄNGE(A7)=4;"Österreich";"Ausland")
B8=WENN(LÄNGE(A8)=4;"Österreich";"Ausland")
B9=WENN(LÄNGE(A9)=4;"Österreich";"Ausland")
B10=WENN(LÄNGE(A10)=4;"Österreich";"Ausland")
B11=WENN(LÄNGE(A11)=4;"Österreich";"Ausland")




Viele Grüße Klaus-Dieter

Klaus-Dieter's Excel und VBA Seite
Online-Excel



Beiträge aus den Excel-Beispielen zum Thema "Wenn-Funktion in Kombination mit Länge bzw. Oder"