Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMENPRODUKT auf untersch., variable Tabellen | Herbers Excel-Forum


Betrifft: SUMMENPRODUKT auf untersch., variable Tabellen von: sunni
Geschrieben am: 14.01.2010 10:37:47

Hallo alle zusammen,

ich habe eine Arbeitsmappe, in die ich per VBA aus einer anderen Mappe 3 Tabelleninhalte einlese. Mit SUMMENPRODUKT kann ich auch super Abfragen starten: Wenn in den Tabellen in einer Spalte "A" steht UND in einer anderen "B", dann summiere die Inhalte einer dritten Spalte:

=SUMMENPRODUKT((Tabelle1!$I$80:$I$358="A")*(Tabelle1!$M$80:$M$358="B")*(Tabelle1!$Q$80:$Q$358)) +SUMMENPRODUKT(('Tabelle2!$G$84:$G$99="A")*('Tabelle2!$K$84:$K$99="B")*('Tabelle2'!$N$84:$N$99)) +SUMMENPRODUKT(('Tabelle3'!$G$84:$G$178="A")*('Tabelle3'!$K$84:$K$178="B") *('Tabelle3'!$N$84:$N$178) )

Leider ändern sich die Inhalte der Tabellenblätter, es können Zeilen dazukommen oder wegfallen. Und dann habe ich einen WERT-Fehler, da die Formel nur klappt, wenn ich mich genau auf die letzte gefüllte Zeile beziehe.

Gibt es hier eine andere Möglichkeit?
Komischerweise kann ich mich auf ein anderes Tabellenblatt einfach mit A7:A1000 beziehen. Aber da frage ich mit SUMMENPRODUKT auch nur in einem Tabellenblatt nach und nicht in 3.

Vielen Dank vorab für die Hilfe
sunni

  

Betrifft: AW: SUMMENPRODUKT auf untersch., variable Tabellen von: Mike
Geschrieben am: 14.01.2010 12:25:23


Hey Sunni,

wieso baust Du die Tabellen nicht so auf, dass alle die gleichen Bereiche haben?

Bei Hinzufügen oder Löschen von Zeilen kämpft man unweigerlich mit Wert-Fehlern.
Versuch doch die Wert-Fehler mit Wenn() abzufangen.

Gruss
Mike


Beiträge aus den Excel-Beispielen zum Thema "SUMMENPRODUKT auf untersch., variable Tabellen"