Microsoft Excel

Herbers Excel/VBA-Archiv

Formel verändern | Herbers Excel-Forum


Betrifft: Formel verändern von: Torsten
Geschrieben am: 18.01.2010 18:27:49

Hallo Experten,

könnt Ihr mir bei dieser Formel helfen:

[=SUMME(WENN((A5:L80="")+ISTZAHL(A5:L80*1);0;1/ZÄHLENWENN(A5:L80;A5:L80)))]

Sie zeigt mir die Anzahl von den verschiedenen Namen in den Zellen A5 bis L80 an.

Meine Idee: den Bezug in der Formel ( L80 ) durch eintragen in Zelle B85. Ist dieses möglich?

Danke für eure Hilfe

  

Betrifft: kürzen und dynamisieren von: WF
Geschrieben am: 18.01.2010 18:40:20

Hi Torsten,

die 2 Bedingungen am Anfang kann man zusammenfassen.

{=SUMME(WENN(NICHT(ISTTEXT(INDIREKT("A5:L"&A85)));0;1/ZÄHLENWENN(INDIREKT("A5:L"&A85); INDIREKT("A5:L"&A85)))) }

Salut WF


  

Betrifft: AW: kürzen und dynamisieren von: Torsten
Geschrieben am: 18.01.2010 19:01:11

Hallo WF,
danke für deine Hilfe.
Kann ich auch die Spalten durch eintrag in A85 aussuchen?

Gruß Torsten


  

Betrifft: da sollte man schon selber draufkommen von: WF
Geschrieben am: 18.01.2010 19:08:19

{=SUMME(WENN(NICHT(ISTTEXT(INDIREKT("A5:"&A85)));0;1/ZÄHLENWENN(INDIREKT("A5:"&A85); INDIREKT("A5:"&A85)))) }

in A85 steht jetzt z.B. C29

WF


  

Betrifft: Danke von: Torsten
Geschrieben am: 18.01.2010 19:16:43

sorry, hatte beim anpassen kleinen Fehler gemacht.

Klappt bestens.

Danke


Beiträge aus den Excel-Beispielen zum Thema "Formel verändern"